[Solved] HaikuDepot/pkgman not responding

I’m trying to install a package and both HaikuDepot and pkgman seems to stall with no response in fetching the repository index?

EDIT after disabling BeSly repo in the repositories things seem to be ok?
Me pings @lelldorin @lorglas

Hello Begasus,

i didn’t change anythink on the server and the files.

Maybe this is a problem with the wifi driver (intel).

Regards lorglas

Hi @lorglas It’s connected with a LAN cable, so not an issue over network. Things seem to be fine now.
PS, have had the issue for a few days here, thought it was something network related, and tried rebooting, but the issue remained until I disabled the BeSly repository?

Hi Begasus, try again. I reboot the server. Maybe its work again.

1 Like

Thanks @lorglas works ok now :+1:

Interestingly, I’ve been having a similar problem, and assumed that it was something to do with a recent hrev. I’ve reverted to an older version (href56141) that definately used to work - no dice. Sometimes can do a pkgman refresh, but can’t do an update… Any advice?

For me disabling the BeSly repository did the trick, IIRC someone at IRC also had similar issues.

I thought that was fixed?

It was for me, after @lorglas rebooted your server things were OK here. But it seems I wasn’t the only one suffering from this.

I think the problem is in the

/boot/system/packages/administrative/ directory

Remove the files in the dir with the following command.

rm /boot/system/packages/administrative/transaction*

Try again your update.

I think, if a server is not responding.

Haikudepot should be inform the user and go to the next.

It were be good, if haikudepot could inform the owner of the repo per mail, that the server has a problem.

Regards lorglas

1 Like

I think @kallisti5 already mentioned this on IRC. :slight_smile:
So something, somewhere should be fixed :wink:

That would be a pretty baf DDOS depending on how many users are subscribed to your repo

Ok, you are right.

Yeah, currently a single broken repo causes havoc in our package kit.

We really need to timeout and “disable” the repo in the current “update session” if it is unavailable within 10-15 seconds or so.

I opened #17815 (Broken software repositories break package kit transactions) – Haiku , please provide some examples there if you get a chance :slight_smile:


Messages from Repositories app can be also confusing…

First alert is telling that the task with the repo takes too long.
If you cancel, the repo is not activated and it ends here.

If you don’t…

The second alert (on the right) gives details about the error that happened but, it is instantly followed by another saying that the task is completed. Note that the name of the repo disappeared.
For info, at the end, the depot was not activated.

Hi Starcrasher,

seems that a new restart of the server solved this problem.

regards lorglas

1 Like

Nice colors!


A post was split to a new topic: Planned BeSly’s repository server outage