[SOLVED] Dosbox and Qemu mouse movement trouble


I have some trouble with Dosbox and mouse mouvement in this app.

mouse pointer does not move correctly and often goes near the edges of the window.

Have you already encounter this “bug”?

I have tried to disable the mouse acceleration of Haiku but the trouble persist.
I also lowered the mouse sensitivity in Dosbox.conf, it helps a bit but the problem persists.


I have seen this bug on Tyrian (Game) if I remember correct…

Edit: Which game do you play, mean?
I just tested the DOS-Box Tyrian version and it is working nice!
Gabriel Knight seems to have a problem at the beginning after starting the game the mouse behaves just fine in retrogames.cz…

1 Like

Gabriel Knight sins of the father but that do it also with Allegro developpment for Dos from my memories.

I think this is the mouse implementation in dosbox throught Haiku making this bug,

I also have this trouble on Qemu…I have tried it with a fresh MS-DOS install, Drivers for mouse and Sound (but the sound don’t work at all here for now)

You said it working nice. Do you mean playing Tyrian with Dosbox? I don’t really understand what you mean by “Dosbox Tyrian version”.

I am interesting to use DJGPP on Dosbox if I can and Allegro. That why a working mouse can be helpfull.

Also I use a Virtual Machine throught VirtualBox for Haiku…This is maybe the trouble.

I also notice the acceleration speed of mouse in Haiku setting pannel stay at the same point. I have moving it down before but that stay in the center after reloading the panel.
How can I disable acceleration of the mouse definitively in Haiku?



Ok the trouble come from VirtualBox apparently. I have tested a VMWare Machine right now with Dosbox and Gabriel Knight and it work well about Mouse.

The trouble have disapear in DOSBOX but not in Qemu after installing the Guest addition package for VirtualBox.
I use the PS2 mouse mode of VirtualBox also.

I can say this is solved for Dosbox part.

1 Like