[Solved] After today's update, booting hangs at network card icon

I do not know what to do…
I was hoping that this update today would resolve the issues webpositive crash issues
Now, the system hangs at network card icon, while booting

Posting from another laptop
I do not know how to sort it out now
Pl. suggest…I do not want to re-install the system


As described in the user guide and repeated every time someone has this kind of problem: enter the boot loader and choose a previous state. You may then be able to retrieve logs to include in a ticket. And given the latest changes, you might be able to boot your current state disabling ACPI in the boot loader options.


@bbjimmy reported the same on IRC (and confirmed booting with ACPI disabled works) but didn’t get around to reporting it yet. CC @korli.


Same for me.

Since last update tonight, it doesn’t boot anymore. It gets stuck after the “Plug-in card” icon becomes in color, the disk icon remains black&white and it never moves forward. Sadly my BIOS doesn’t allow disabling ACPI so I can’t try if it would make it boot.

Here I took a screenshot of the debug logs while booting, but I can’t see anything that seems like an error.


FWIW, I had the same problem here after updating the system last night.

1 Like

You don’t need to disable it in BIOS, but on Haiku’s boot menu. Search for “Disable ACPI” on the already linked user guide for the Boot Loader.

Edit: In any case, seems @waddlesplash already fixed the regression!


today, when I ran the update command, pkgman said there is nothing todo

Regression fixed but not pushed to repo’s?

First time that I put my hand inside bootloader…there was no necessity for me from last 3 years…

Nightlies are built once a day. You need a bit of patience for them to become available. Also, sometimes builds fail, or the builders have issues. Again with the patience thing :smiley:

Currently, I see that the latest successful build for x86_64 bits is hrev57442, while the fixed regression is hrev57445.

The latest x86_64 build (for hrev57445) seems to have failed due to a network related issue (while the builder tried to download some needed packages). It happens sometimes.

The x86 32 bits version, on the other hand, should have hrev57445 ready for update.

1 Like

Be Cool,
wait for next hrev, 57 445!
Disable ACPI at boot and update Haiku!

1 Like

Just updated Haiku to hrev57447, and now the system boots fine!

Thank you for the quick response @waddlesplash!

I also updated to hrev57447, boots up without issues

I am back to square 1. Webpositive crashes when I attempt to open Haiku-os webpage or any other page…

Do not know what to do

Thought of uploading program crash data…core file…size is 5.6GB…everybody will hammer me…if I upload this