Software Updater

I’ve tried to perform an update using Software Updater, both Haiku and HaikuPorts repository come back as ‘Refreshing repository … failed’. I’ve tried pkgman full-sync and I get the following error message:
Refreshing repository “Haiku” failed 0%: Out of memory
Refreshing repository “HaikuPorts” failed 0%: Out of memory

Anyone know of the solution to this? Thanks!
This seems to be the issue…awaiting fix.

It looks like waddlesplash has marked this as fixed, but how can the system be updated to fix this problem if pkgman won’t perform an update?

To fix pkgman you need to install previous openssl package which you should find in one of
/system/packages/administrative/state_* folders. After that you should be able to update normally.

That makes sense but I don’t have any previous states available. Is there another way to accomplish this?

If you can mount beta1 iso image you can get this package from it.

1 Like

… »same« here, i can’t acitvate the Haiku package sources in my control panel.
I deactivated them for testing, after my last succesful update was many weeks ago.

Fetching repository info *** Out of memory *** No error

Right now clasqm’s and KapiX sources are available only?
I’m using hrev52295, 32 Bit Vintage)

This seems to be a wrong error from openssl package. The real error is likely something else.
At this point it’s better to use a nightly.

1 Like

We want to make sure the beta1 (either fresh or fully updated) to beta2 update works fine. If everyone keeps breaking their beta1 installs, that’s not great.


I wanted to stay on beta1 but it was broken and I got the impression that ‘nobody is still on beta 1, everyone is using a nightly’. Of course I’m not a dev, I know you guys are constantly improving the code. It just seems to me that a beta should remain somewhat frozen for testing, only receiving tried and tested improvements. I know this will all get sorted out, it’s the nature of creating Haiku.

Well, after I shut off the beta1 HaikuPorts repository, it should be impossible for anyone to break their existing system now, for better or worse. So we only have nightlies and beta2 to worry about now.

1 Like

The problem is that the server links are changes after a sine time beta 1are out and the most of us change to the nightly to have the newest version running.

I do not know the beta will be generated but normaly if you update you system with beta1 running with the right server links you system wenn to beta2 automatically. I does not know how long the beta1 server address for haiku and ports are available after beta2 but abytime you need to change.

Our original plan for a release a year seems about right. Now it’s a year and a half since beta1 and it’s becoming difficult for us to keep the maintenance for it up. So we’ll try to hold to the schedule for the next releases, and hopefully manage to keep more users running the beta.

The process itself is in beta-testing, you see :blush:


Meta beta. :wink:


Maybe if original Beta 1 repository is still reachable, it is necessary to provide in this repository several key updates just to ensure the possibility to upgrade from that updated Beta 1 to Beta 2.

Upgrading from beta1, either stock or with all updates (save the OpenSSL ones that break it), to a current nightly, is already possible and works without any intermediate updates.

1 Like

Well, I think my nightly build install was broken by the Software Updater as well. The last full update that it gave me was on April 17th when I got the April 16th hrev54051 nightly build. After that the Software Updater would only update my Haiku Loader (now at hrev54134), makefile engine, userland fs and occasionally the webpositive package as those are the only packages that have been getting updates in the last 3 times I ran Software Updater. Any suggestions for fixing this would be greatly appreciated. Thanks.

Try pkgman full-sync from Terminal.

Thanks Humdinger. That seems to broken the logjam and it now is updated to the current hrev54134 nightly build. I did try that terminal command last week but unfortunately did not fix the issue then.

On reboot though my comouter was stuck at the Haiku loader screen with the loader icons not lighting up even when i hit my notebook’s keyboard keys and also plugged in a external keyboard and hit it’s keys to force the loader to continue but that didn’t work either. My notebook (an old white MacBook) needs the keyboard keys pressed to get the loader to finish loading.

To get it to fully load I went into the Boot Options and manually selected the Current Version as the Boot Volume and it finally fully loaded.

Thanks again.

Glad you got there in the end. :slight_smile:
I, too, had to resort to “full-sync” recently to kick the system to update again recently. For me it went smoothly though. Software, right…? :roll_eyes: