So I powered up an old laptop yesterday

Just wanted to see if it still worked. Was quite surprised when I was greeted with the old Haiku boot manager (the one that looks like the BeOS R5 one), and hey - check it out!

TIme sure does fly.


Is there a a new one? (I know about the EFI one, but that looks almost the same as the one from BeOS…)

That’s a mighty old hrev in there! :smiley:

Oh maybe not… I’ve been using EFI for ages now so have kind of forgotten, though I still have the BeOS one installed on another machine :slight_smile:

Sure is, don’t think I can update it either since so much is different now! Would have to be a fresh install, so think I’ll just leave it be :slight_smile:

1 Like

Still got an old laptop here that still boots Haiku (every once in a while - too slow for building packages for me), bumped that to R1B4 also, still working fine for it’s specs. :slight_smile:

1 Like

My first Haiku install was in 2010 on a Lenovo Ideapad S10 netbook. Must have been the first alpha that came out. I can remember I was really surprised that even wifi worked.
Don’t have the machine anymore … and no screenshots, sorry :wink:

1 Like