Shutdown doesn't work

I had install the last beta Haiku months ago. I like it, it works very good, I changed shell to mksh because on FreeBSD I am using ksh :).
The problem is because shutdown doesn’t work (I turn off laptop)> I didn’t find any log related and Transmission which I read that could be problem I didn’t find on my system.
And Haiku is installed on old HP 2000.
Thank you.

And one question more: Is it possible o have luakit web browser in Haiku, please. I saw Qutebrowser which I have on FreeBSD but I didn’t installed. On FreeBSD luakit work very good.

Thank you.

Do you mean that the shutdown is not completed, or that the shutdown command is not executed?

For example, you get the window that says “shutting down”, but the PC never shuts down.

The issue is probably the transmission-daemon started by the launch-daemon crashes at the shutdown.
The launch-daemon entry in the transmission recipe should be removed completely:


I get the window that says “shutting down”, but the PC never shuts down.

Which file should I edit, please? I search for transmission but I didn’t find except there is in /boot/home/queries/ empti file. As I read that5 problem is old 5 years and is exist still?

Thank you.

So you dont get a "transmission-daemon crashed window if you try to shut down your computer? If so, why do you think the shutdown issue is transmission related? Do you have transmission installed? If so does your computer shuts down successfully of you uninstall transmission? If transmission is not installed or no change observed after the uninstall: then it is not transmission related, and you should give us a more precise problem description.
Have Haiku ever managed to properly shut down this specific computer? If yes: what have you changed since then? Try to boot a recent nightly from a usb disk and try to shut down. What is the result?

1 Like

@extrowerk I think that OP made a search on the forum to see if there was a known solution to his problem. Since it’s a shutdown problem he probably ended with few threads related to the Transmission issue. So he checked if he had it installed and the answer is no. He told us so we can exclude it.

@fernandel Try to see in /var/log/syslog if there’s something it can be there.
Did it worked by the past? If so did you check if a (temporary) return to bash make it work? Something you could try is opening a Terminal and try with command line, see what it says. If it doesn’t work, you can open aKDL session and type shutdown there, it should work.


I did check syslog but there are nothing. It never worked. It works just restart. I did return to bash and it is the same. I also format disk and install again and it is the same. I did try shutdown in terminal to and it is freezing. It closed some deamons and that it is.
How can I open aKDL session, please?

Check here.
What you can do to narrow down the problem is to play with boot options to see if you can make it work. Then report it as a hardware problem.

In my experience, older laptops tend to have pretty wonky ACPI implementations. I have one that only powers-off complete under WinXP or Haiku, but keeps draining the battery if I “power off” from Linux (no matter what I try :smiley:)

Some BIOS allows you to set different version of the supported ACPI (you might want to try with those), or completely disable ACPI, and rely on the older “APM” for power-managment things.

I’d try that in case those options are available.

Thank you very much for all help.
The laptop is very old and was ready to recycling :). Anywhere, it is good for learning Haiku.


Now I am having the same shutdown problem.
What do I have to look for in syslog?