Rust crash trapped in debugger using VMware Player


I had a crash from a segfault in my Rust crate while testing. In order to try to get a hint why it was happening, I tried selecting debug from the crash requester. Since it couldn’t load the debug info from the debug build in Rust, I selected download gcc_debuginfo thinking I wouldn’t be here long and would just exit the debugger quickly. Now there’s no way to exit the debugger. When I select the close gadget it won’t kill the thread being debugged and it still says “Installing package gcc_debuginfo…” at the bottom. I can’t shut down the system because the debugger prevents the OS from shutting down nicely. I tried exiting the virtual machine but it suspended the session and reloaded it when I tried to restart so that I still can’t exit the debugger. Do I have to delete the VM and reinstall? Fortunately I have most of my changes committed to GitHub.


I noticed that gcc_debuginfo wasn’t installed from HaikuDepot but installing it now made no difference. Am I still trapped? I can’t quit it!

Maybe Ctrl-Alt-Del (or whatever the equivalent is in the VM software) to get the Team Monitor and then kill the Debugger. Or open a Terminal and try kill -9 there.


Sending Ctrl-Alt-Delete from the menu did the job. I was finally able to kill the debugger! Thanks!

1 Like