Running Haiku R1/beta1 on one-decade-old Mac laptops

On newer MacBookPro’s, the situation is better. I run Haiku on 11.3 gen (mid 2014). The trick is to stay away from USB3 devices. Audio via headphones (HDA driver) works after a warm reboot from OSX, wired network works (Broadcom 570x driver), video is VESA @1600x900 (non native, blame Apple), no WiFi (Broadcom 4360). Not ideal but usable when plugged in.

On the polycarbonate MacBooks I’ve tested Haiku on, I usually just take out the disk, install Haiku on the disk in a PC, and then replace and restart from it. The same trick worked in my 2011 MacBook Pro. No fancy tricks needed.

I don’t think we have to have an own topic for every OEM, and this is a forum, the bugtracker is in this direction:

I am new around this forum so please forgive me if I am still breaking some etiquette that I don’t know about. I will take a look at that thread. I think I have been reading some posts there, but since I am still exploring if I am really able to install it, I think it is too early to fill a report there. I will check the tools you recommended innkeeper to provide more useful info for developers. For now I just wanted to share my experience with these two models.

I think I have been experimenting with the 32 bit version, because it was supposedly more compatible with old software. If the Live CD boots with ReFind, it will probably also boot when installed to the disk. At this time, I would prefer to use the version that allows the best compatibility, including old software titles. But I will experiment also with 64bit. I think I have also downloaded that image…

If you have a polycarbonate MacBook, remove the HD, install Haiku on it from a compatible PC (or through a USB to SATA, etc. through a VM) to normally install Haiku. Put the disk back in the Mac and restart. Wait for Haiku to be detected (the ? will flash for a minute) and at least from all my adventures with Haiku on the Mac, this seemed to work with the Nightlies (not sure if it does now).

I have this white core 2 duo macbook that is currently used by another member if my family. It boots the 32bit install DVD. I will try to install it into a partition. The other machine, the macbook pro, doesn’t have a DVD drive and through USB it only seems to be able to boot macOS. If all goes week with the macbook, I will probably extract the ssd from the macbook pro and use the macbook to create the haiku partition.

Success! One thing I just love about BeOS and Haiku is how easy and quick an installation or even a full system clone can be done. The hard part, in this case, was keeping track of all the screws from the MacBook Pro. I had to take the SSD out and then was able to install Haiku into it using a USB enclosure connected to the other Mac that already had Haiku.

It booted right away at the first time, without having to setup any of those boot time restrictions. On first look, it seems to be using full screen resolution, parcial trackpad support (no right button and no scroll, mouse pointer seems a bit more nervous in this Mac), wifi (detects networks nearby and easily connects to my iPhone’s personal hotspot), seems to detect both processor cores and is able to switch completely off after shutdown. Sound recorder displays a graph, so it seems to be able to use the microphone, but there is no audio output. I saw a few app crashes, but I would say it’s normal in a beta version.

I will do a software update soon and see if anything gets better. Right now I am very happy to see this old computer much faster than I had ever seen it at launching apps. :smiley:


Yeah, mine (also 13’’ 2008 mac) is a Broadcom internal wifi.
In Linux, this hardware has the non-open module requirement bcm43xx

I used to run haiku on a macbook core duo (not core 2 duo, this one [1]) and it ran OK. I don’t know how similar they are. I had to use OSS (opensound) to get any audio and I seem to recall that only gave me very very quiet audio output. I last tried it before haiku had wifi support so I can’t speak about that, but you might be able to change wifi cards or you may need to install a wifi firmware. I am surprised you have to disable APIC and APCI, that could lead to some other problems. For example, the machine does not turn off automatically because APCI is disabled. With regards to the iSight, there is almost no support for webcams in haiku, only some very old non-isochronous ones work as far as I recall.

I haven’t tried it in a long time so sorry if this old report is somewhat irrelevant, but I just recalled that it ran a bit better than it sounds as though yours does.

[1] MacBook "Core Duo" 2.0 13" (Black) Specs (MacBook, MA472LL/A, MacBook1,1, A1181, 2092):

1 Like


I have Macbook Pro late 2008 with SSD and Win7 32 bit running on Virtualbox. And it’s reasonably fast, so, IMHO, bottleneck of slowness of Haiku in your case might not related to “outdated” machine. At present I’m experimenting with my old EEE PC 701 and live USB Haiku session. It’s quite fast, taking into account slowness of CPU

Do we have a general OS performance testing tool that could send telemetry (at the user’s explicit request) back to bug tracking?

May be a much nicer way for users to report what is/isn’t working, and also give an indication of where real-life performance bottlenecks are for the core developers to work on.


Well, after fiddling a bit with these two Macs, I managed to get it to work in both. Here is my report and review of Haiku R1/beta1.


It was everything going just fine, with the normal issues you would expect from beta software, and I even decided to start contributing to the translation of the user interface.

Then I screwed :roll_eyes:

I decided to make the macOS partition smaller to make space to a second Haiku installation. It would be useful for the testing of the 64 bit version separately. But after repartitioning the SSD, I lost the boot section for Haiku and could only boot macOS.

I had to take out again those 20+ screws and take the SSD out one more time. I put the SSD in the USB enclosure and installed the 64 bit version into the recently created partition, using the Haiku Install DVD from another Mac. I also asked the Installer to write again the boot sector to the previous (32 bit) partition. So, I hoped to have access to both 32 and 64 bits. But it didn’t work. It seems that the boot sector created by the 64 bit installer won’t boot the 32 bit partition.

After installing the 64 bit version, Haiku 64bit would boot by pressing Alt and then selecting “Windows” from the Apple boot menu. Booting from the rEFInd boot manager didn’t work, or required turning off some features in Haiku. While running 64 bit, any of the 32 bit applications I had didn’t work, which I believe is the currently expected behavior.

Then I did another experiment. I wrote the Haiku boot manager to the disk, using Installer. I now regret doing that :slight_smile:

Once again, I lost access to Haiku, and probably I will need to take the disk out one more time…

1 Like

I have a 2007 MacBook Pro that’s been sitting around collecting dust. This is my evening activity. Do I need to install rEFind to get it to boot from the disk?

It depends on the Haiku version you will be using. First I have tried with 32bit, and because that version does no support EFI, I needed rEFInd. Then I tried the 64 version, and it was able to boot from the regular Apple boot menu (pressing Alt after turning the Mac on).

I am now doing a complete disk formatting and repartitioning. I think I will start using the 64 bit version and I will see if it works without rEFInd. I bet it will.

Okay, thank you for letting me know. I’ll give it a shot tonight (EST) and see how I go!

I am still fiddling with it. The Apple boot menu has its weird mysteries…

64 bit works perfectly without rEFInd.


In my case, I had it working but now it doesn’t. Still trying to figure out the reason. I did a clean install of MacOS, created more two partitions and used another mac and an external USB enclosure to install Haiku to the SSD. Now it doesn’t boot Haiku.

Probably it has something to do with the bug referenced here.

Unfortunately, after following the instructions from that page, I get the Haiku EFI boot manager and it recognizes the Haiku partitions, but the video Mode selection section says “None” and there is no option to go ahead with the boot process…