Running Haiku .iso on Parallels 8

I’ve been trying to get Haiku to run inside a parallels (v8; MAC OS X Mountain Lion) running on an iMac with a quad-core intel i5; using the latest .iso file (as of 5 Feb 2013).

I create a new VM, point it at the .iso file and tell Parallels it’s of OS type ‘other’.

I see the Haiku splash / loading screen but it jams with the leftmost 4 icons lit and the 3 rightmost icons unlit (the 1st unlit is the ‘chip’).

I’ve looked into previous issues with Parallels and have tried elements such as ensuring there’s plenty of RAM available to the VM and disabling networking; nothing seems to help.

Is there something obvious I’m not doing or a way of getting diagnostics from Haiku?

Many thanks


Hi Mark,

I have early 2011 13" MacBook Pro w/ Mountain Lion and Parallels 8 that I have successfully booted Haiku R1a4.1 and nightly images on.

I’ve never been able to get the .iso image to boot in Parallels 7 or 8. I usually use the anyboot image instead of the iso. Renaming the anyboot image file to end in .hdd allows Parallels to see it as a virtual hard disk. When you add it to the VM, it will want to convert it to the new parallels virtual hard disk format. Go ahead and let it convert the image. You should then be able to boot Haiku.

The anyboot image does not have any extra space so you will still need to install Haiku onto a separate virtual hard disk.

This process has worked reliably for me. I will try a new nightly image tonight and see if I run into any issues.

It is a known problem that Haiku doesn’t work straight off the bat with parallels desktop.

Use the already reported workaround to get it working and check out this page for more info: