RTL81xx: unable to get ethernet working at all

I recently tried out R1B4, and while most things were functional, ethernet was not. It loads the rtl81xx driver but is unable to communicate at all.

-> listdev

device Network controller (Ethernet controller) [2|0|0]
  vendor 10ec: Realtek Semiconductor Co., Ltd.
device 8168: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

From a few quick searches on here, I have found that this device SHOULD work.

Syslog shows it tries to communicate for DHCP, but never gets a response. I know my router works fine and DHCP is enabled. If I try to switch to a static IP, it’ll pretend to work but the “Network is unreachable”.


KERN: /dev/net/rtl81xx/0: link up, media 0x900030 quality 1000 speed 1000000000
KERN: register_domain(4, link)
DAEMON 'DHCP': /dev/net/rtl81xx/0: Send DHCP_DISCOVER to
DAEMON 'DHCP': /dev/net/rtl81xx/0: Timeout shift: 500 msecs (try 1)
DAEMON 'DHCP': /dev/net/rtl81xx/0: Send DHCP_DISCOVER to
DAEMON 'DHCP': /dev/net/rtl81xx/0: Timeout shift: 1000 msecs (try 2)
DAEMON 'DHCP': /dev/net/rtl81xx/0: Send DHCP_DISCOVER to
DAEMON 'DHCP': /dev/net/rtl81xx/0: Timeout shift: 2000 msecs (try 3)
DAEMON 'DHCP': /dev/net/rtl81xx/0: Send DHCP_DISCOVER to
DAEMON 'DHCP': /dev/net/rtl81xx/0: Timeout shift: 4000 msecs (try 4)
DAEMON 'DHCP': /dev/net/rtl81xx/0: Send DHCP_DISCOVER to
DAEMON 'DHCP': /dev/net/rtl81xx/0: Timeout shift: 8000 msecs (try 5)
DAEMON 'DHCP': /dev/net/rtl81xx/0: Send DHCP_DISCOVER to
KERN: [net/rtl81xx/0] watchdog timeout
KERN: /dev/net/rtl81xx/0: link down, media 0x22 quality 1000 speed 0
DAEMON 'DHCP': /dev/net/rtl81xx/0: Timeout shift: 60000 msecs (try 6)
DAEMON 'DHCP': /dev/net/rtl81xx/0: Send DHCP_DISCOVER to

The network tray notifies that it is “Configuring” until about a minute later, it turns into “No link”. This repeats and repeats and repeats.

I have been unable to try nightly builds due to problems (AKA they KDL).

Indeed this driver is known to work. Do you have a firewall that could block the traffic? It can happen in you run Haiku in a VM, for example. Unless you have another OS on that machine that is connecting, you can check with another cable. Depending on your router settings, you may have to allow the network MAC address to connect.

About nightly problem, don’t forget to file a ticket for the KDL, if you didn’t already. Or, if it’s already reported, vote for the ticket.

I have checked router configs and there is nothing that would prevent the network device from connecting. I have no restrictions that prevent new local devices and from router logs, no communication between the device actually happens (but it is powered). I also use this same machine as my main Linux machine, and with the same device and cable, am making this post right now, so I know that all hardware aspects should work.

I’m out of ideas. You’d better file a ticket for that too. You will have more chances to get devs attention on the matter. The forum can be quite active and here your post you will be buried in a week or two.

Try manually setting the ip and gateway in network settings :slight_smile:

Tthis has worked for me in the past.

1 Like

Doesn’t work as mentioned in the OP. No longer complains with “No link” but can’t connect to anything.

The “watchdog timeout” indicates there is some other problem here. I think there’s already a ticket somewhere with basically this issue, but the precise cause remains unknown…

Had this problem, too. Had a ethernet cable to the router through to a Lan over Power thing by TP-Link.
Had to remove both adapters, then it worked again.

Figured out a workaround. I was booting in UEFI mode and unable to use MBR, but just enabling CSM in my systems BIOS was enough to get it working. I still booted using UEFI into Haiku, but I guess something CSM does makes it supported.

Checked and diff’d syslog, but there was absolutely nothing different until it talked to DHCP.

There are changes at the drivers, my rtl8188 eu does not run sience beta 4 anymore, the problem could be here?