Restoring BeBox Dev kit

Hello folks,
I have an original BeBox Dev kit - a few details missing, but appears otherwise healthy. Early Dev kits shipped without the front faceplate with the iconic blinkenlights, so I may have to 3D-print a replacement like @Dr_Slump did here:

I was able to use the firmware update floppy to bring the bios to version 1.1d7.1.

image

Startup shows the Be logo, and pressing left shift or space at the Be logo should show boot options. However, I appear to have none.

The machine has one SCSI HDD and one IDE CDROM drive. I will check the cabling to make sure they are wired correctly, but my problem is another: how do I boot to start the install? I have the install CD for 1.1d7, but I presume IDE CDROM was not bootable back then… or was it?

7 Likes

Bios update results

image

1 Like

Boot selection:

image

2 Likes

IDE cdrom were definitely supported since the Preview release, not sure about the earlier releases.
Did you put the dr7 disc in your drive and did a rescan for bootable disks?

I just spent the last two weeks bringing a BeBox back to life - it’s pretty fresh in my mind. For whatever reason, under various releases including the 1.1d6 that came with my machine I was unable to boot from an IDE cdrom, trying three separate drives.
I ended up using a scsi cd-rom.
Other things that blocked my progress initially were:
A bad floppy drive - my rom updaters kept reporting a bad checksum for the image - sounds like your floppy drive is in better shape.
And
The scsi hard drive was so dead that scanning for drives failed hard and blocked the boot.

So make sure you are using known good drives - there’s a guy on eBay selling the toshiba XM-3601B scsi CD-ROM drives.

The 1.1d7 on archive.org is good - I was able to install it if the boot rom was DR8 or lower. After a couple of rounds of this sort of thing I ended up using scsi2sd - v5 works but is slow - V6 with a large card split into multiple scsi IDs. Device 0 I set as a 1gb drive and used ISO Buster (as other threads suggest) to extract the correct session on a given distribution cd image as raw, converted to ISO, then dd’ing that .iso to to the start of the sdcard. When you boot you’ll see the “cd” as device 0 along with whatever other devices you defined on the card.

Hope some of this helps

1 Like

Also, as other threads note (posting this mostly for posterity and future digital archaeologists):

Do hook up a serial terminal or terminal app via a null modem to serial port 4 (the bottom one) 19200-8N1 and hold down the F1 key during boot until output starts. There will likely be clues as to any issues, though many “warnings” are spurious or handled.

This isn’t an issue yet - since you can’t see any boot devices yet - but some of the releases I tried would fail as the kernel came up with 128mb RAM installed. This took a while to sort out, I ended up reducing the RAM in my Box to 64mb to reliably boot any or every release.

Finally, the etherlink II isa Ethernet card I installed would fail under DR8 - even though it worked fine under all other releases. The solution is to track down the BeBox update to 8.2 and installing it. Right now this url works - https://ftp.zx.net.nz/pub/archive/ftp.be.com/pub/beos_updates/dr8/DR8.2_Update.tar.Z - otherwise just search for DR8.2_Update.tar.Z

Those are the rest of the roadblocks I encountered.

2 Likes

Indeed I did put the CD in the tray and ask for rescan. But while I see a flashing CD led during bios startup, I do not see it flashing when I ask for the rescan (?).

image

Can you check the serial debug messages as suggested by CaliforniaElectric to see if the machine recognize your cdrom drive?
What size is the scsi hdd in the BeBox?

Yes, the flashing at startup is just the CD-ROM drive itself - it would demonstrate the same behavior if no data cable were plugged in.

I will try to get the serial next.

The SCSI HDD (health not verified yet) is a Quantum Fireball, I believe 500M.

I have ordered a scsi CDROM as another writer suggested — it will come in handy here or elsewhere.

Would just like to say, this seems like a very cool project. :slight_smile:

1 Like