[Resolved] Network connection on Asus EeePC 901

I’ve just installed a Haiku trunk image to a small partition on my EeePC 901 20GB where it now forms part of a triple boot system (Ubuntu 8.04.1, Xandros).
Haiku works well and is amazingly fast (boots in 11 seconds).
However, there’s no internet apparently because no drivers for the EeePC network cards (RaLink Unknown device 0781 and Attansic Technology Corp. Unknown device 1026) are provided in the Haiku image.
I’ve tried this driver http://www.haikuware.com/view-details/drivers/network/attansic_l2zip built by karl but it doesn’t work for me.
I also tried to contact the author of the source code http://svn.berlios.de/viewcvs/haiku/haiku/trunk/src/add-ons/kernel/drivers/network/attansic_l2/ for this driver to know if it in a working condition or not right now. But I couldn’t get a contact address.
Does anybody know anything more about the status of network drivers in Haiku for the EeePC?

He has a membership on haikuware(http://www.haikuware.com/ithamar/), you could send him a email (via Messages>Send Email) on that page.

You could also send a message to this mailing list: http://www.freelists.org/list/haiku,
That may get you a faster reply.

Thanks to Richie Nyhus and tonestone57 for the replies.
In fact, shortly after my first post, karl supplied me with the email address of the developer working on the Attansic driver for Haiku.
However, based on what you have said, it may be better to post to the mailing lists.

Incidentally, Haiku works really great on my Asus EeePC 901. It boots in 11 seconds (compared to 50 seconds for the Senryu VM to boot on the same machine). I really would consider Haiku as my primary OS on the EeePC (I triple boot Ubuntu, Xanthos and Haiku) if I could get an Internet connection as 95%+ of what I do is on the Internet.
Although an ethernet driver would be very useful to me, as extreme portability is one of the major advantages of netbooks, the ideal would be a driver for the wireless card (RaLink RT2860).

The status of the Attansic driver:

You can always search on dev.haiku-os.org for changesets ( these are changes done to Haiku by developers ).

Post on the mailing list to see if a developer will fix this driver for Haiku.

PS Drivers found in the source repository are not added to Haiku image if they are unfinished or crash ( or under GPL license ).

You can try contacting the developer first. He also has a EeePC. That’s why he was looking at getting the Attansic driver working in Haiku.

Developers create drivers for hardware that they also own. Ask nicely and if he has no time to work on it then try posting to the mailing list.

Haiku is really fast but can still experience data corruption ( unfixable and requires to re-init the partition ) & other bugs. I enjoy using Haiku myself but would not make it my primary OS until it reaches mid to late BETA. I use BeOS’ chkbfs to check for data corruption. I believe it may be on Bebits too.

No developers are working on Wifi drivers for Haiku. Haiku has FreeBSD network layer but I’m not sure if that helps in porting over Wifi drivers - about half of the wired ethernet drivers are FreeBSD. Another option for wireless networking is ndis wrapper. I really can’t say if Wifi will make it into R1 or R2 but I don’t believe it’ll happen any time soon. You can always ask on the mailing list and see what the devs have to say about it - they would know better.

Attansic is done and should be part of Haiku image.

“Update Attansic L2 driver with latest source from FreeBSD, it is now fully functional!”

See here:

Please take a look at this ticket: #1050 (implement a WiFi stack) – Haiku , and stand corrected :wink:

It is in progress, but a lot of work… so if anybody feels like helping, please comment on the ticket or post to the development list.


[quote=tonestone57]Attansic is done and should be part of Haiku image.

“Update Attansic L2 driver with latest source from FreeBSD, it is now fully functional!”

See here:
Yes, thank you.
Actually, developer Ithamar had told me about this yesterday and I tried the driver that had been newly built from the updated code on the Haikuware site. However, I couldn’t get it to work for me.
OK, so I’ll wait for the Haiku raw image r28752 to be available which should be very soon.
It’s great that at least things are moving.

Just an update on my search for an internet connection to Haiku on the Asus EeePC 901.
I tried the Haiku raw image r28754 (http://haiku-files.org/raw/) but unfortunately the built-in attansic driver didn’t detect my ethernet card.
So, still on tenterhooks…

Ithamar wrote:
“Please take a look at this ticket: http://dev.haiku-os.org/ticket/1050 , and stand corrected ;)”

OK, I stand corrected. :slight_smile:

Thanks for the update and your hard work. Regards,

@ Paul
File a bug report over at http://dev.haiku-os.org
That way one of the developers can have a look, see what the issue is and maybe fix it.

Also, you should include Ethernet information ( in Haiku, listdev or in Linux lspci -nn ). Just include the Ethernet stuff with your ticket. Knowing your vendor & device IDs for the network card can help out.

Might be a good idea to see if your LAN works with FreeBSD because that is the driver used in Haiku.

[quote=paulfxh]Just an update on my search for an internet connection to Haiku on the Asus EeePC 901.
I tried the Haiku raw image r28754 (http://haiku-files.org/raw/) but unfortunately the built-in attansic driver didn’t detect my ethernet card.
So, still on tenterhooks…[/quote]

Obviously it won’t work, since you probably don’t have an Attansic device. I bet you have an Atheros L1 device, and AFAICT the driver for that card isn’t ported to Haiku as we speak. See http://wiki.freebsd.org/AsusEee#head-0ec25ebfd5cc91803a27ffefe989f34ee19d887e

EEE PC 701 and 900 have Attansic L2, FreeBSD driver called ae.
EEE PC 901 and 1000H have Atheros L1, FreeBSD driver called ale.

That’s interesting indeed but what lspci tells me on the EeePC 901 is

[quote]01:00.0 Network controller: RaLink Unknown device 0781
04:00.0 Ethernet controller: Attansic Technology Corp. Unknown device 1026 (rev b0)
So I have to believe that I need the attansic_l2 driver.

Actually, I’m in communication with Ithamar about this driver and don’t believe any further action is required right now.

I have the 900HA and the latest driver doesn’t work here either.

listdev under Haiku tells me:

device Network controller (Ethernet controller) [2|0|0]
vendor 1969: Attansic Technology Corp.
device 1026: Unknown

Looks like the 900HA and 901 have the same card that doesn’t work with the driver. I wonder, does your 901 have the real hard drive (like mine) or the SSD Paul? Also wonder if Ithamar has the same device ID as us.

@ Paul ( and Karl )

Fredrick is correct about Atheros L1 because:

  1. The link he provided is off FreeBSD site and they know the hardware
  2. I looked up the PCI ID for Attansic over here:

You’ll see your Device ID of 1026 refers to:
1026: L1 Gigabit Ethernet Adapter

The L2 has a Device ID of 2048.

Fredrick’s link states:
“Atheros L1 FastEthernet
This one is second generation of L1 controller which is supposed to be heavily modified by Atheros after acquiring Attansic.”

Atheros bought over Attansic. Atheros improved Attansic’s L1 controller and released it under the Attansic name.

You actually need a different driver ported for your EeePC 901.

I’ve created a ticket suggesting porting Atheros L1 network driver from FreeBSD here.

Woohoo, Ithamar ported it already and it works! thx


Yes, I now have an ethernet connection to Senryu on my Asus EeePC 901. I’m using the new <a =http://www.haikuware.com/view-details/development/app-installation/senryu-developer-edition-raw-image> Senryu raw image that karl created after Ithamar got the driver sorted.
These guys work fast.
Obviously a key element here was the <a =http://www.haiku-os.org/community/forum/network_connection_on_asus_eeepc_901#comment-10365> correct identification of the network card in the EeePC 901 which was only posted on Wednesday last. Now in less than 48 hours, my problem is resolved.
That’s impressive.
Thanks to everybody for helping me out.

“These guys work fast.”

Haiku has a FreeBSD network layer. This allows using FreeBSD network drivers on Haiku with very few, minor changes. This makes it quick and easy for developers to get wired networking going on Haiku.

That’s also why the nforce driver was updated so quickly.

The EeePC either use the Attansic or Atheros drivers depending on the model ( two different network chips ).

Ithamar included both of these FreeBSD network drivers and now all EeePCs should have networking supported.

Plus other computers that use those same network chips.

using the Alpha 1 image on my EeePC 901 did not recognize the ethernet aob (no cable attached as I do not have wired connections at home).

my EeePC 900 showed up the attansic ethernet wired device (again, could not test it)

(neither netbooks showed any sign of wifi devices obviously)