Request to developers regarding printer support

Please, add support for the Canon LBP3000 printer. Unfortunately, I did not find this printer in the list.

1 Like

Have you tried using Gutenprint’s “Canon LBP-3360”? (assuming that’s close enough).

Can’t find much about that LBP-3000 model, but other printers on the “LBP” line are supposedly more or less compatible with PCL5 drivers, so you could try that one too.

I tried gutenprint LBP3360. It did not help. Tried other options (LBP). Everything looks smooth on the screen, the document is sent to print, but the printer does not print


Using the “PCL5 Compatible” driver instead of the Gutenprint one didn’t help either, I assume? (sorry for insisting, it isn’t clear to me if you did tried that one already).

If none of the available drivers works, I wouldn’t keep my hopes high, as even on the updated gutenprint drivers (5.3.4) I can’t find any reference to that model (or any other LBP one for that matter).

Maybe some other forum user has some tips/workaround to share, like using IPP to send the print job to a CUPS server on a Linux machine (not ideal, but… better than nothing).

1 Like

I also tried this option and others. Nothing helps. This printer model (LBP3000) is old (bought in 2008). Probably for this reason this printer was not included in support

Is there a generic text printer option?

Canon LBP-3000:

  • PCL6 compatible
  • USB 2.0 connection (or legacy)

The thing is to use the print preview and print job setup clarifying pages to print. if you see the print preview but no printing - check the print job setup.

CUPS setup is just an alternative.

Otherwise, add a bug report to:

NOTE: CAPT driver: agalakhov/captdriver: Driver for Canon CAPT printers (

The screenshot in the attachment shows at what stage the process stopped


  • Was this the exact same issue with the PCL5 driver?
  • Is this a USB 3.x → 2.0 (i.e. legacy fallback) direct connection to printer?
  • Save your syslog info.
  • Save info from this command: listusb

Give that info within the bug report (i.e. attachments) for main devs.

I have tried all the options that the system offers. The system is installed on Virtualbox with USB2. Tried to connect to different USB ports of the laptop.

Can you try with Haiku running directly on the hardware, e. g. by booting from a USB stick. Just to rule out possible error sources from the VM software.

Have you set up the usb handower in virtualbox? What you try to accomplish is impossible without passing the (whole?) USB controller to Haiku.
A virtualized OS as the name implies do not have access to the physical hardware in default.

I just created a bootable USB of Haiku and booted up on the laptop. Used the “Try Haiku” mode. The result is the same.
I also use Linux on Virtualbox. The printer prints. Perhaps Haiku has its own characteristics.

I just created a bootable USB of Haiku and booted up on the 2 laptops. Used the “Try Haiku” mode. The result is the same.

1 Like

What driver is used, CAPT or PCL?? Could you retest using PCL5 and PCL6 drivers on Linux?

For LBP3000 - CAPT-driver

I have already tested these drivers (PCL). This printer was not easy to get to print. I initially tried many options that the system offered to connect the printer out of the box. Did not work out. The LBP3000 was not listed either, so I downloaded the driver (CAPT driver for LBP) from the Canon site and did the installation following Canon’s instructions and making adjustments suggested in the various forums. On one of the forums, I was kindly provided with a separate “block” for the ccpd service. Without it, and without commands like “sudo systemctl daemon-reload” and “sudo systemctl reenable ccpd.service”, the printer won’t print. Perhaps it’s not the driver, but the correct configuration of the services. If the printer is connected to the wrong port, printing will not work. If the service is not in autoload, then the printer will not work normally.
The commands that prevent the system from automatically installing the printer when connected to the USB also helped (so that the printer is not duplicated and there is no confusion with ports). On the manjaro forum, it was recommended to write a rule that “binds” my printer to a specific lp port and prevents the printer from being duplicated when reconnected.

which application are you printing from ?

I tried to print a “test page”

Today I looked at the Canon website and compared two drivers (Canon LBP 3000 and Canon LBP 3360) and realized that they are different and not interchangeable. The Canon LBP 3360 driver has an extensive list of printer models compatible with it, which, unfortunately, does not include the Canon LBP 3000. The list of printers compatible with the Canon LBP 3000 driver includes only one model - this is the Canon LBP 3000.