RemoteDesktop fails to connect


#1

Installed R1/beta1 into two virtual machines. SoftwareUpdater ran successfully on both.

I am able to ssh from one to the other. However, RemoteDesktop fails to connect:


#2

Do you get an error message? RemoteDesktop just operates over SSH, so if you can connect via SSH, you should be able to use RemoteDesktop…


#3

This is from a 64 bit install:
screenshot1


#4

Strange…

Can you check the syslog of the remote machine? Is there anything interesting in it?


#5

I looked at /var/log/syslog on the server and found a lot of interesting stuff in it, but nothing that seemed like a smoking gun for this issue. So, I checked syslog on the client and still nothing.

I contemplated this issue and found it strange that RemoteDesktop would complain about port 10900 before it had even authenticated the ssh connection. So I tried the following command: RemoteDesktop user@192.168.1.243 -s 22 -p 10900

That definitely changed things. It asked for a password. I keyed the password and then my client machine desktop went completely white with no mouse.

I checked the server and there is evidence that the client connected. There is now a Terminal tab in Deskbar and when I click on it, it reports “No windows”. ProcessController shows a thread titled “/bin/bash -c echo connected; export TARGET_SCREEN=10900; /boot/”. And syslog now has something too (screenshot to follow).

I don’t know how to recover the desktop on the client, so I tried a Ctrl+Alt+Delete and I got a “Team monitor” pop up window that allowed me to kill RemoteDesktop and my desktop came back. And I see some interesting errors in the client Terminal (screenshot to follow). This recovery does not reclaim the resources on the server side though.


#6

Server syslog:

screenshot2


#7

Client Terminal:

screenshot2


#8

I have now installed the 32 bit ISO on both my virtual machines. Ran SoftwareUpdater successfully on both.

I repeated all the steps above and observed identical symptoms.


#9

Yes, it appears there’s some sort of bug then… Please file a ticket.


#10

Done (see https://dev.haiku-os.org/ticket/15106).

Thank you for your support.