Recipe question

Hello. I’m trying to build the “gnucobol” recipe, but I’m having an issue, surely because I’m not still get used to the haikuporter tool.

The architecture section of the recipe is the following:

ARCHITECTURES="!x86_gcc2 ?x86_64"

I’m using a x86_gcc2 version of Haiku, and in the haikuports.conf file, I have enabled this setting:

#     Allow build of untested recipes. '?x86' for example

# --------------
#     The primary architectures you wish to compile recipes for.
#     Defaults to the current primary platform.
# --------------
#     Secondary platforms you wish to build packages for.
#     Example is x86 (gcc4) packages on a x86_gcc2 (gcc2) system
#     Default is no secondary target architectures.

When I tried to build the recipe, I get the following message:

Warning: skipping gnucobol-2.2, as the recipe is broken
Error: package gnucobol-2.2 cannot be built for architecture x86
Error: No version of gnucobol can be built

Dumb question here:

Why I can’t build an “x86” package, if the recipe had it as a secondary architecture?

Thanks in advance!

I suppose haikuporter stumbles over TARGET_ARCHITECTURE being “x86” as well, when the primary arch should be “x86_gcc2” for 32bit hybrids.

1 Like

Thank you @humdinger!

I will modify the configuration.

I updated the haikuports.conf in the following way:



When trying to build the package, the error is:

Warning: skipping gnucobol-2.2, as it is broken on the target architecture.
Error: No version of gnucobol can be built

I guess this is because the package had the value “!x86_gcc2”. However, how I can build the package for the secondary architecture (x86) ?

You build for the secondary arch with haikuporter gnucobol_x86.

1 Like

Thank you @humdinger for your help!