Realtek RTL8102E/RTL8103E Family PCI-E Fast Ethernet NIC (NDIS 6.20)

I have a Toshiba NB205 with this chip set for network. in Network Pref nothing is shown. I saw another thread where someone was compiling a driver for rtl81xx. Is my chipset supported. I have tried with nightly build GCC4hybrid from 2/9/10 yesterday

Windows shows these hardware IDs


these compatible IDs

and this matching ID

I will post the output of listdev tomorrow or friday. Is there any other command that would be helpful

Your network card is:

Realtek (chipset)
Vendor ID: 10ec
Device ID: 8136

You’ll need an updated Realtek driver. There is an open ticket about updating the Realtek driver already. You can update & compile the driver yourself or wait for a developer to get it done.

Refer to this ticket:

EDIT: Added comment to above ticket asking for progress report. Check @ end for any new comments.

First, I noticed there has been a recent change to the RTL81xx driver posted in the Source Activity, thus try the latest nightly build tomorrow to see if the problem is fix. I know I will be trying over the weekend.

If that does not work go to the website Haikuware, do not download the driver I placed there instead download the instructions on how to modify the RTL81xx driver that I did post for downloading at:

Using those instructions you should be able to patch your driver to work with cable networking.

However, two addition things:

  1. While use of a Static IP has always work fine once I found the right address to use I have had problems getting DCHP working on some networking systems, not surprising considering that it is just an ID patch and thus uses the code of a similar but not identical chip (something I hope the latest software update to Haiku will fix, even if my patch is needed for the NB205).

  2. The instructions are a little long, I hope to post a simpler doc soon, but have been very busy the last couple of months. Hopefully, I can do this over the weekend.

        Good Luck
                  Earl Colby Pottinger (Another happy NB205 owner)

The fix was made to enable 8139C+ support. I do not believe it will fix your issue but trying a nightly newer than 35452 will let you test it anyways.

You likely need the network driver to be updated to a newer release. Since Jack says he is unable to then another developer will have to do this.

Your network controller is newer and requires more recent driver to recognize your hardware. Two other people had the same issue and ended up compiling their own driver in the end rather than waiting.

EDIT: Way to confirm you have network driver loaded:
do “ls /dev/net” and see what you have in there


I will try the above this weekend.


Earl Colby Pottinger

Nightly build 35500
I tried following your instructions for changing the rtl81xx driver but ran into a problem. I am probably not using disk probe correctly. When I use diskprobe on the rtl81xx driver file and search for 0x30800000 it finds nothing. Also when searching for RL_HWREV nothing is found. If I search for 8100E one instance is found. What exactly are you using diskprobe on and how. Is there anyway you can send me a copy of your modified driver because my info from syslog is exactly the same as what is in the instructions.

Off topic for this post but is your audio working correctly. I only get the onboard speaker and no way to change to headphone.



I am now posting this from Haiku on my toshiba NB205. I tried using diskprobe on the rtl81xx driver file and searching for hex 80 30. It found two instances of it. I tried replacing the second instance with c0 24 and it worked. I got lucky as I was just fiddling with it without really knowing what I doing.

Thanks for everybody’s help.


Using R35500, use diskprobe to find 24C0000 (00 00 C0 24 in diskprobe’s window) and changed the ‘C0’ to ‘80’.

Tested ok, including DHCP.

Thanks for sharing all your experiences, I followed through and was able to fix my realtek high definition driver issue without having to undergo the same level of difficulty. I just had to update my current driver using the driver CD and it did the trick.

My Realtek ethernet card works:

Realtek PCIe GBE Family Controller
ID: 10ec
Device: 8168

Thx for this driver…