Realtek ALC887, ALC233 - problem with audio


#1

Hi,

I tried to get a working audio on Haiku using these chips:
Realtek ALC887, ALC233 and Focusrite Scarlett Solo 2gen USB

None was working or even appeared in mixer audio settings.
I use VMWare Player and self-compiled Haiku
The Nightly build downloaded from the official site didn’t solve the problem as well.

Have you used these sound cards on Haiku?

Thanks for any info or tips.


#2

Hello. If you are using the gcc2_hibrid (32 bit version), try installing the Opensound package from HaikuDepot.


#3

Thanks, I have installed the opensound package.
It works on x86_gcc2_hybrid with Focusrite Scarlett Solo which is displayed as Creative AudioPCI97 (ES1371).
Unfortunately, the sound has disruptions while I’m playing mp3 or youtube, so it’s far from perfecion.

Why it is not working on x86_64?


#4

However, the Realtek ALC887 works and sound is ok.
Thanks!


#5

Hello. As far I know, USB sound devices are not well supported yet.

Unfortunatelly, the OpenSound package still is not available in 64 bits version.

Great! Nice to hear that! :beers: :+1:


#6

I tried once again with Focusrite Scarlett Solo and sound is much better when I have changed Buffer size from 1024 to 256 in ASIO Control Panel on the host (Windows 7).
There are no more distortions and sound breaks, so it is acceptable, but still not perfect as there is some kind of noise in the background.


#7

@neutrino thanks for share this info :+1:
Is very useful to know this workarounds, if someone also had the same hardware.