Realtek ALC883 audio driver

OK, I am getting my Haiku box setup closer to being done but I need to get the audio working.

So what I am wondering if, has anyone gotten the onboard Realtek ALC883 working on their PC? I have found there is a Linux driver for it so I was hoping maybe somebody else had done a driver for themselves for Haiku.

Here’s hoping.

Maybe you will have more luck with OpenSound. You have to disable default driver before installing it:

mv /system/add-ons/kernel/drivers/bin/hda /system/add-ons/kernel/drivers/bin/hda.disabled
installoptionalpackage opensound

Ok Diver I did what you suggested. Actually I cut and pasted the nice long command you typed out for me and hit the Return( ya ya I know, I did the hard work…LOL… thanx for doing it)

Now I can click on the speaker Icon and get “Could Not Find Mixer”. So I went to the media preferences and it shows Master Output “Not Connected” So I go into the Audio settings and for both input/output it shows “None” OK so for shits and giggles I restarted the Media Services and I get a couple of screeches out of the speaker and then again nothing.

I did find that someone else had the same issue but the where running under VMware, not as a dedicated system like I am. I will keep looking around to see if I can find out anything else.

Even after reboot?

Yup even after a reboot. But I have been playing around and I now have in the Media Audio settings prefs it shows audio mixer and ati hd audio. I went into the media settings and selected ati hd for both input and output and have tried channel out 0 thru 4 (RAW). Now in audio mixer it shows that it sees something as it would let me change the output DB.

On the Ati HD Audio settings page I can change what jacks do what. I have selected the rear green jack and tried all the modes available. I am wondering if the driver may be putting the sound out the spdif and not the jack. hmmmm.

I have installed the Audio Demo package and played something from there and from a normal cd. The media player plays the track and shows that it thinks there is audio going out via the bar indicator.

I have beat my head against this for an hour now and I am going to give it a break and then take another try. If you have any suggestions let me know.

Thanx in advance

Hey Diver,

Ok I just decided to bring my machine up to the current nightly. I now have both HD Audio and ATI HD Audio in the media prefs. Whats weird is if I select HD Audio now I get sound but it sucks. It like it is skipping and this is from both a cd and a file. I am wondering if Opensound is fighting the built in Audio driver now that I put the new nightly on? How can I disable opensound?

I’m getting closer, I have some sound now. Better than an hour ago. LOL

Yes, “HD Audio” comes from /system/add-ons/kernel/drivers/bin/hda driver, “ATI HD Audio” comes from OpenSound. They don’t work together as they attach to the same hardware which often results in KDL.

I’m not sure but you can try to move /home/config/add-ons/kernel/drivers/bin/oss_loader to the Desktop and restart media services in Media preflet.

OpenSound comes with several cli tools. You can try to play with these:


I have sound!!!

Ok so I couldn’t figure out how to get rid of opensound and since I can’t seem to bring Team Monitor up I redid my system from scratch. Used the new nightly. I still did not have sound so I did what Diver had told me and moved HDA and installed opensound and I had sound right away. YESSSS. So I play a track from a cd and then went and selected a track from the audio demo I reinstalled and I lock up mediaplayer. Aargh. Since I can’t start team monitor I just restarted the system. WELL now when I put an audio cd in the cd drive it does not mount it. I had already set my prefs to mount all drives when I redid my system. Arghh think I am gonna take a break and come back at it l8r.

You can kill a prcess using ProcessController or using Vulcan death grip:

Please report your problem about cd mounting to and attach your syslog:

Hey Diver, Thanx for the info on the process controller.

As for making a bug report, I am wondering because I am mucking with getting my system all running that I have maybe caused the problem myself. Changed a setting and didn’t realize it. I don’t want to make a bug ticket that is really user error. What I was going to do is when I redo my system again I have a list of things to do to make my system run (ie install opensound) and if the cd problem shows up again put in a ticket. I am going to wait for a couple more changes in the nightly before doing the redo.

Or if you think it may be better to put it in now also I will. Let me know what you think.

Thanx for the help I do appreciate it


IIRC /boot/home/cd stores some settings. You could try to delete them.