Ralink2860 wireless troubles

Howdy, Haiku guys,

I read an article recently about how to install Haiku in virtualbox. I saw a presentation on Haiku at the last Florida Linux Show. I had head of Haiku even before that, but never did anything about it. I’m running Haiku in a qemu vm right now (typing this in it), and just put r1 alpha3 on my eee 901, Everything seems to be working fine on it except that I can’t get wireless working. I have /dev/net/ralink2860/0 visible in the network monitor applet with “no link” after it. I followed the guide, “joined” my essid, provided the passphrase, and nothing. My wireless network is encryped with WEP.

I ran install-wireless-firmwares before this, but I don’t think it provided any firmare for my card.

any ideas? Not having wireless is pretty much a show-stopper.


Hey again,

let me try to ask this a different way. After clicking on my network status applet, I see my access point and signal strength. Above it, the device has “no link” after it.

In /boot/common/settings/network I made a file called “wireless_networks” and edited it with my ssid name and password. In the same directory I see a file called “interfaces” which shows device and network.

Where do I go from here? Since I am so new to Haiku, I don’t know what the expected behavior is, whether I’m dealing with a bug or just a misconfiguration on my part. What’s the network status applet supposed to look like when online?

thanks for your patience!

Best way is to test your wireless on Open AP with NO security. Then, if it connects you know that its not driver issue. If you can turn off WEP for a short time on your router and check it then you’ll know where to focus your debug effort.

thanks, I turned off the encryption for testing.

I also just updated to the latest (at the time I did it) nightly build.

When I booted to the usb stick the nightly is on my wireless adapter status was “ready” and I was happily pinging stuff all over the place. Then I ran the installer and booted back to the hard drive. The wireless adapter status was back to “no link.”

Strange. Updating to the nightly image didn’t update everything?

Seems it didnt. Theres a thread about how to update properly. Try those suggestions.