R1/beta1 - no sound


#21

I’m using 32bit haiku on hardware and get no sound. I installed from the depot the optional OSS package. However, I read elsewhere I need to blacklist the current HD audio addons. I found them, but am not sure how to do this. The instructions posted on how to achieve this seem to be out of date, even the file directory structures they list aren’t quite like this one. I added a text file with the addon to not load as in the instructions but either I did it wrong somehow (wrong extention, wrong syntax in the file, maybe bad spelling?) or it’s no longer applicable.

Is there a preferred way to blacklist add ons in the beta? I looked also for the add on in the depot by showing ‘installed packages’ and couldn’t find what I was looking for as a standalone, but did see it in the base haiku package, but I can’t do anything to any part of a package in terms of it’s contents; there’s no right click options or anything to find when I see what I presume is what I am trying to blacklist (Haudio).

Any help or guidance would be appreciated.


#22

https://www.haiku-os.org/guides/daily-tasks/blacklist-packages


#23

That’s what I followed and had no change, OSS didn’t assume priority. I’ll just wait until another beta or update. I don’t need sound, and if it’s going to be fixed in the future, I just won’t worry about it now.