R1/beta1 - no sound


#1

Ok, so I understand that the OSS driver doesn’t work with 64-bit, but wasn’t it a bit stupid to remove it from the repositories so that those of us using VMWare on Macs don’t get ANY sound even when we go to the 32-bit version? I could see it if someone came up with an audio driver that worked instead, but WTF?


#2

The old way of installing this is, in a Terminal window, typing:

installoptionalpackage -a opensound
[Edit: as extrowerk indicated, this command does not exist in beta]

And you can find the list of old optionalpackages at http://www.haiku-files.org/files/optional-packages/
[Edit: Formerly, you could also extract these. I think there may be a ReadMe file.]

However, I don’t know whether this is applicable to Haiku R1/b1. My search-fu fails at finding a more recent method.


#3

There is no such command in beta.


#4

The right way to install aditional stuff in Beta is the Packagemanager.
So maybe in the comandline a
pkgman search oss gives some hints…

or you go with the gui version. not shure if it is there i just found this one
https://depot.haiku-os.org/#!/pkg/opensound/haikuports/4/2/-/-/2/x86_gcc2?bcguid=bc216-JFKU
Maybe this helps?


#5

Well, I found a workaround for this - Since I’m using VMWare I had a nightly version with OSS already installed, so I copied the opensound-4.2-2-x86_gcc2.hpkg file to a USB stick and then copied it into the R1/beta1 /boot/system/packages directory and ran the install program. Now I have sound in my 32-bit R1/beta1.

When I ran the nightly image and went to haiku depot, opensound still shows up, and the R1/beta1 still shows the open sound add-on in the /add-ons/x86/media directory but the hpkg file doesn’t appear in haukudepot. That’s just plain dumb.


#6

That’s actually the current correct way to do that. No commands required.

Honestly you shouldn’t need oss…perhaps change the emulated sound card in VMware.

I think haiku Depot may have a separate branch for beta1 support? And the oss package isn’t tested thoroughly yet so it isn’t there yet.


#7

I see the “Open Sound” package when searching for “opensound”. Beta1 32bit here.

People updating from a nightly should make sure they point the repo URL in the Repositories prefs to “r1beta1” instead of “master”. Dunno if that’s relevant in this case…


#8

I’ve encountered this before, but in Virtualbox. We did talk about this in some other topic, though I can’t quite recall where. I tested with Linux distributions and they have sound, so it may be Haiku. Anyhow, I’ll try @FurryOne’s solution and see if it works.


#9

Well, I assure you that when I installed the R1/beta1 and checked HaikuDepot there were only 3-4 entries that started with “O”, and I had “All Repositories” listed. I see this morning that it now lists over 50 entries that start with “O”, including OpenSound. Maybe the R1/beta1 repositories were’t originally online?


#10

No you probably had Featured Packages checked. As it is by default… unfortunately this leads a lot of people to think packages aren’t there at all.


#11

On first launch, it appears that downloading the info for all the packages is kinda slow. It may just not have finished by the time you searched.

There’s a ticket to add a barberpole that shows what HaikuDepot is doing. That way the user can be informed that data is still being downloaded.


#12

No, I didn’t - I’ve been using HaikuOS since the project started and always make sure that’s not checked.


#13

Are you running Haiku in English?


#14

Being in New York, yes.


#15

Well I ask as there is the potential that running it in a non english locale could be causing slow populating of HaikuDepot.


#16

My wild guess here is that there is no OpenSound for 64-bit platform. Thats why its not listed in HaikuDepot. If its loaded for ‘FurryOne’ in 32 bit, it should probably be safe to add a recipe for 64 as well?


#17

The recipe is here: https://github.com/haikuports/haikuports/blob/master/media-sound/opensound/opensound-4.2~git.recipe
Somebody should test it on 64 bit and report the results. Then we can enable it, but just after somebody tested it.


#18

This is better: https://github.com/haikuports/haikuports/pull/2465


#19

I have installed R1beta x64 on my hard disk. I have no sound. If i do listdev i see:
device Multimedia controller (Audio device) [4|3|0]
vendor 1002: Advanced Micro Devices, Inc. [AMD/ATI]
device 1314: Wrestler HDMI Audio

All seems ok, but when i play a mp3 or a video i don’t hear any sound


#20

I didn’t found any previous ticket refered to that sound device.

@Sanandreas: please, fill a bug report at:
https://dev.haiku-os.org/

Include the complete listdev output. Thanks :slight_smile: