Question about WPA auto-join

I’ve finally started to seriously experiment with the Haiku install I set aside when setting up this laptop (it’s been interesting so far!) Some things are working great, and some things aren’t. Particularly irksome at the moment, I can’t seem to get Haiku to automatically join my wireless network; it just says “configuring…” and then “no link” on boot, and I have to join with ifconfig, after which it works fine. I’ve seen another thread suggesting to set up a wireless_networks file in /boot/common/settings/network containing the SSID, encryption type, and password, which I tried, but no such luck; it seems to just ignore it. At first it didn’t work at all; I have the latest nightly build, and I saw an issue in the bug tracker with corrupted wpa_supplicant, so I uninstalled that and reinstalled it fresh, and that got it working, but I’m having no luck at all with getting it to auto-join. Is there a step I’m missing?

Hi commodorejohn!

Auto-joining is currently a bit of a hassle. Passwords aren’t yet saved and that wireless_networks file doesn’t work either.
After you’ve booted up and end with “No link”, you either choose the wireless network to join from the NetworkStatus icon in the Deskbar. Then enter your password. Every time…
Or go the ifconfig route. Personally, I have a little script in my ~/config/boot/launch folder:


alert --idea "Join a wireless network." "OK"
ifconfig /dev/net/iprowifi3945/0 join MyNetworksSSI MySecretPassword

Actually, as I have two routers in the house, one called haiku-bottom, the other haiku-top, I have a slightly different alert that let’s me choose:


button=$(alert --idea "Join a wireless network." "haiku-bottom" "haiku-top")
ifconfig /dev/net/iprowifi3945/0 join $button MySecretPassword

Anyone with an idea how to test when the configuration after bootup ended in “No link”?. Then I could pop up the alert after that’s finished. Or just join the network without alert…


I’ve just one wireless network, so I added this to my UserBootscript:

#! /bin/bash
sleep 10
ifconfig /dev/net/’re.using/0 join password

Seems to work.

Yeah, I just went with the launch script for now…still, it would be awfully handy to have a proper wireless-config utility. As light and screen-space-efficient as Haiku is, it seems like it’d be perfectly suited for laptops and netbooks, but it’d get old having to manually ifconfig for every coffee shop you go into.

This is something I intend to work on Real Soon Now ™. Which hopefully means in the next few weeks. Because yeah, that is annoying.

Will this work only with the nightlies or will it also work in the alpha r3 ? Haiku will work fine with open networks with my Atheros wifi. I can see my network and it show up in Network Preferences. I just don’t get the password dialog box.

I got the password dialog box when I tried the 44242 nightly, but it seemed to crash more than alpha r3 and even if I entered the info it would not connect.

Thinkpad X40 w/ Atheros chip, see profile for more specs.

Hi natgab!

WPA encryption doesn’t work in Alpha3, but should work for newer nightlies. Works for my atheroswifi netbook. Your Atheros 5212 should be supported, too. No idea what’s wrong with your setup, though. If you give it enough time to conclude the initial configuration after bootup with “No link” and then enter the correct password, it should work. Otherwise, have a look at the syslog, maybe there are some hints there…