QT / KDE curiosities


#1

Don’t have a clue where else to go or what to do with this one (hit all the most obvious places before using this option). Running beta1 (hrev 52295+129)x86_64 on a Lenovo 320 i5 7th gen laptop with 8GB of memory on its own partition booting through rEFInd, with the usual issues involving networking requiring a hard line for the internet (A minor inconveience at worst) and the hda issues that seem nearly universal with certain cards. These aren’t that big an issue, to be truthful (though a hint would be appreciated, already tried disabling the hda driver , etc etc, all the suggested fixes I could find).

Biggest quandry is I can’t get an app window for ANY piece of software involving either of these.They all start (show in Tracker, register for memory, all of that) but never under any circumstance do I get an active window or an alert of a problem of any kind.
Would not seem to be hardware related, everything else I’ve played around with so far has worked quite well, but anything to do with actually being productive is a no-go.
While I am NOT a developer or sys-admin, I’m not afraid of the shell, or writing/editing scripts, and have a reasonably good idea of where everything is or should be.

Any suggestions would be greatly appreciated.At this point I haven’t even got a clue as to what information anyone might need from my end to help me answer this one. Been around since the BeOS 4.5 Personal days and my inability with sorting this out on my own is frustrating. I wa still using BeOS 5.0.3 for personal lstuff long past its expiration date, until I lost that box to a flame out on the motherboard


#2

Do you mean you can’t run Qt apps but everything else runs normally? Has it started only recently or it was always like that for you? Have you checked the usual stuff, i.e. starting failing apps from Terminal and checking their output, checking /var/log/syslog for anything suspicious, running checkfs /boot and so on?
In any way, beta1 is quite dated at this point, so it worth trying a nightly.
Regarding HDA driver, try blacklisting it and installing OpenSound (available in HaikuDepot)


#3

Yep, been messing with this since hour one. I’ve a couple odd questions – why are most of the user config files nothing more than a single line containing nothing more than HMF1? Could also use a hint on preferences that seem to reset themselves to the default as shipped, usually on a cold boot. As much as it pains me to admit defeat, I had pertty much decided to head over and grab the latest nightly. As for the rest of your questions, yes to all, been searhing through the forums for possibilities for quite a while at this point, no love found. Thanks for the recommendations though. Off to grab a freshly minted version …


#4

Haiku stores most of its settings in binary BMessage format. They can be viewed with/bin/message command.


#5

I somehow missed it, but this combined with apps failing to start possibly hint at some problem with the disk where you have Haiku installed.


#6

Hopefully not a physical drive issue, while the laptop is a 2017 I got it new in the box (or so it seemed, still had factory seals, no signs of exterior damage or tampering). I’m going to do a fresh install of a minty clean nightly as you suggested and see where that gets me, then start boning up on my Terminal skills, I seem to be more than a bit rusty. Just to check, though, are there any issues using GParted from the live (usb drive) version to prep the partition? The app problem seems to be entirely confined to QT or KDE flavors, the native apps all run quite nicely. KWrite, KDevelope, QTdesigner, etc., all “start”, they get memory addressing and such, but there are no windows, no evidence of them at all until I hit ctl-alt-del and kill them from there. Never had anything like this occur on any of my previous Alpha installs.


#7

GParted should be fine. Is there any output if you start Qt apps from Terminal?


#8

Won’t have a clue until I do some re-installing, I went ahead and cleared the volume before installing hrev 53113, so minty fresh is really fresh. So far all is well. Thanks for your suggestions, greatly appreciated.


#9

Didn’t know this until now, believe it or not! Thanks! :slight_smile: