PSA: Haiku can only mount "insecure" NFSv4 shares

If you’re trying to access NFSv4 shares from Linux, you may found yourself stumbling on

mount: Invaild Argument

In that case, you should try to add insecure flag to your share in /etc/exports


Then run

# exportfs -rav

Now you should be able to mount the share on Haiku

This is noted in exports(5)

General Options

secure This option requires that requests originate on an on an Internet port less than IPPORT_RESERVED (1024). This option is on by default. To turn it off, specify insecure.


The insecure option in this entry also allows clients with NFS implementations that don’t use a reserved port for NFS.

This should probably be a bugreport to Haiku, maybe the issue can be fixed there.