Prototype BeBox, not booting

Hi All!

I have previously posted about this on reddit, but things seem pretty active here too, so I thought I’d give it a shot…

I am currently trying to resurrect what I think is the first Rev 6 prototype - SN PPC95111000, dual 66mhz.

It was donated to a Computer Club at a University here in Perth Australia by a local software author back in 1998 or 1999, along with a Rev 8 BeBox, dual 133mhz. I first joined the club in 2002, and while the dual 133mhz was working at the time, the dual 66mhz has never worked. It lacked RAM, Video card, floppy drive, everything… it was just a case, faulty power supply, motherboard and IO card

But I like a challenge… so it’s at my place for long term restoration… here’s what I’ve done so far:

  • Repaired power supply - had popped caps, now working fine, voltages all check out etc
  • Replaced power switch - old one had impact damage and would short out or disconnect load. Sourced identical replacement from Digikey
  • Replaced push buttons on front - mushrooms had broken off, found replacements, replaced.
  • Obtained RAM (2 x 32MB DIMMs)
  • Obtained S3 Trio64 PCI video card - card didn’t initially work, pulled BIOS chip from card, cleaned contacts, working again
  • Obtained floppy cable (mine only one was a two connector one with a twist in the IDC cable. Got a period correct three connector one)
  • Attached floppy drive (had two in spares)
  • Attached IDE DVD-ROM (Pioneer DVR-111) using 40 conductor cable

So, here’s where we are right now in terms of config:

  • Working AT PSU
  • Pioner DVR-111BK Optical drive, set as IDE master
  • IBM Deskstar 500GB, capacity clipped to 32GB, set as IDE slave
  • Working floppy drive
  • 2 x 32MB RAM DIMMs
  • Rev 6 Motherboard
  • IO Card

At startup, it seeks to the floppy drive.

Thinking the Boot ROM might be hosed, I downloaded the boot disk image from, wrote it to a 1.44mb floppy disk on a mac using “dd”, put it in the floppy drive, and it read the image. I left it for about 10 minutes of inactivity, powered the machine off, removed the floppy, attached a serial cable, powered it on holding down F1, and it now displays this at bootup, which it didn’t do before:

Configured boot device is ‘/dev/ide_disk_master’
fsmount failure
fsmount failure
fsmount failure
fsmount failure

A very kind person captured the serial output from his BeBox at - the one I’m working on doesn’t display anything before the “Configured boot device is” line, unlike this one, but it’s a Rev 6, so… who knows.

I’m trying to boot off a CD (in the DVD drive, IDE master) I burnt on a Mac using an app called “Burn” from the bin/cue files from archive dot org BeosVersion5.0.3IntelAndPpc

It doesn’t show anything out of the VGA port - I’ve tried the card in all three PCI slots too. I’ve tried the graphics card back in a PC before and after and it works on both occasions.

Do we think it needs to be an IDE CD-ROM vs DVD? I can probably dig one up from a friend if so…

Things I have tried:

  • Booting with no RAM = no output on serial
  • Booting without one or both IDE devices attached = errors on serial

Usually, if you have only one disk controller, disk drive is master and CD/DVD drive is slave. You should only set DVD as master if you have a second controller.
It should with the mount failure.

I went with DVD as master since that’s what boot device was set to, and I don’t have an install on the HDD… I’m pretty sure I tried it the other way around though too.

You should be able to get into the debug menu where you can scan for bootable volumes… I think a bootable CD would show up there even if not on the master… so set it up as it should be then use that method to find the CD and boot it… I think that is how it is supposed to work.

Also not sure what you mean about the ide drive capacity being “clipped” its entirely possible that drive just isn’t compatible with the old ide controller. You might want to try two other ways one with a small 2-4GB industrial CF disk, and the other with a CF to SD adapter, both of them in an IDE to CF adapter… either one of those ways should give you a 100% compatible IDE drive of the correct size… also imaging a raw VM image to the drive might work note you’re have to ensure the MBR gets written when you do so as sometimes the host OS blocks writes to the MBR.

The debug menu I assume you mean the boot selection menu that comes up on video when you hold down shift (or is it spacebar?) at boot? I’m not even getting VGA sync out of the thing, so I’m not sure if that will work…

The drive I’m using lets you set a jumper on the back to change the capacity from 500GB to 32GB, but I was worried like you are that may even be too big, so I’m seeing a retrocomputing friend in the next couple of days to pick up some old <3.2GB and <8GB hard drives, along with an IDE CD drive (and SCSI CD and HDDs), and I have a SCSI2SD in the mail to me now too.


well one of thoughts ought to be able to boot it let me know how it goes!

Wasn’t the R3 update borked on BeBoxen?
@theducks, if it’s an old unit, it won’t accept newer roms and versions of the OS, so you’d need a really older version, 5.0.3 definitely wouldn’t work on it.

Try an older bootrom floppy, like the PR or even DR8.
Is that the whole debug log out of the serial port you get, those 4 lines?

Not sure if your graphic card is supported by the older roms, depending on the version…
There’s a compatibility list on the archived website if you go way back, and the list is quite short.

I thought it was the Rev 5 boards with 94xxxxxxx serials which weren’t compatible with the newer releases, and the Rev 6 and Rev 8’s were?

“fsmount failure” repeats over and over after the “Configured boot device” line, but other than that, it’s the only output, yes.

… Although, I just left it for a while, while typing this, eventually it said “decrementer exception occurred”, and is now at a “?” prompt… if I type “?” it says “huh?” … interestingly a google search for that brings up a PPC manual -

I’m also now trying with an IDE CD-ROM drive, and a 6GB IDE HDD.

Ok, so say I want to try DR8… any idea where I can find a boot ROM restore floppy image?

Edit: Messing around a bit, got this output:

Rev 8 are the latest so they are compatible with all versions of the OS.
Rev 6, not sure if all are or only the ones that were updated, as in Be was offering a motherboard replacement with the larger flashrom.
Edit: only Rev5 came with the smaller flashrom.

On the same ftp where you got the R3 bootrom floppy, all the updates are there.
Not sure if DR8 can be installed from an ide cdrom drive though, you’ll have to check the old bebox faq.
PR1 does support ide cdrom drives, try it instead of DR8.

Thanks! I had a bit of a look around there… the R3 that I imaged onto the floppy seems to have a bunch of header information, is 1.44Mb and the instructions say to dd it to a floppy, while the updater in just begins with Joy!pffpwpc

According to the README file which links to, seems to be for the BeOS “ROM Updater” application and is only a few hundred k?.. so may not be a full disk?

I’ve previously viewed the BeBox owner registry, and against all odds, at the end of the world here in Perth, there are three - the two owned by the computer club, of which this is one (and the other locked away due to covid19), and a third owned by… one of my friends from high school, so we’re catching up in a week or two to validate hardware, swap boot devices etc and have a play, but I’d like to give it as much of a shot as possible first

1 Like

There are two ways to update the boot rom…

  1. You use a floppy with a disk image. This is at boot time.
  2. You run an app and that allows you to drag the boot rom image on to it and that then does the update. This is whilst the OS is running.

The header you mention looks like a bog standard PowerPC PEF executable format header, so I’d assume it might be the UI based OS updater??

IIRC I used an older boot rom the entire time I owned my BeBox… it might have been the PR2 one, but I think maybe the R3 one. It allowed more graphics cards to work… the Matrox cards had issues with showing the Boot logo unless you used the older rom, as the newer ones had the card removed because the boot rom implementation had bugs.

It’s also worth noting - if your graphics card is not supported you will see absolutely nothing until the OS booted to the point it is loading the desktop.

Thanks! That was my guess too - interestingly the r3.2 bootrom image also has that signature in it, so I guess there’s a small filesystem. I don’t think I want to mess around with potentially making a PR bootrom image file using the header and footer, so… I’ll have a sleep on it and think.

In the meantime, if anyone has a Rev 6 board and can capture the serial 4 output at boot, that would be great!

Here’s the serial log from my BeBox, it’s running DR8 at the moment.
Rev 6 boot log

Hmm! Thank you. That is quite different, in that it shows a lot more details before booting than the one I’m working on does.

Could I ask you to power your system down, unplug the floppy, scsi and IDE cables, boot, and wait for it to error to the “?” prompt, and type “pci” and let me know if it shows a VGA or network card? I’m a bit concerned that this one just says “sorry” when I run that… although, the UART that drives the serial port hangs off the PCI bus, so I guess it must be somewhat working at least

Ohh I should have checked - this is a Rev 5 board! I guess I’ll change my strategy on that basis and keep trying.

If it’s a Rev5, last ROM you can use is dr8.

technically couldn’t you just upgrade the rom? Or where there other major changes between rev 5 and 6 I don’t think there were?

Yeah - and DR8 doesn’t support booting from IDE CD drive, so I’ll have to track down a SCSI CD-ROM here… not the end of the world, but finding one which can read CD-R might be a bit tricky. I’ll give it a shot :wink:

There’s an old page which says there were other changes… the ROM is on Rev 5s is socketed, so I would think that if it was as simple as just replacing it, they would have done that, vs ship whole new machines to people.

One good solution nowadays is to use a scsi2sd, it can simulate a cd/dvd.
If anyone has used such a solution on beos.