Probs with creating a 32bit Haiku-os usb in Haiku64

My situation:
Using an Acer emachine intel Atom processor, 2gb, 160gb hd with Haiku-os 64bit installed.

Objective: To create a 32 Haiku-os usb stick to use to install on an Acer Aspire 1350 - which doesn’t boot from usb.

Limitation: Only have CD burning - not DVD.

Have a recent 32bit Nightly on a CD as its less than the 700MB limit, but on booting goes to: ‘Haiku Loader’ …with Can not continue booting (Boot volume is not valued.)
I have the option to choose another boot option but my 64bit usb stick is rejected as it 32 bit is required.

Solution: Would be to create a 32bit Haiku-os usb stick
…but :

Downloaded a 32bit Haiku-os ISO file.
Prepared the USB stick…using DriveSetup
Did the ‘diskimage register’ cli requirement.

But when I get onto the Installer process, the 32bit iso is ignored - not listed as an option and so creates a USB using wots on the HD including all the additional software Ive installed - resulting in a 64bit USB instead of 32bit.

Does one have to have a machine running 32bit Haiku to create a 32bit stick?

Why do the instructions state to download an iso file when its just going to use what ever is on the Haiku HD ?

Or - wot am I missing here?

LOL…and dont say, 'A newer machine !!"

download the 32 version ISO file.
use the command dd.
does it not work?

I get:~/Desktop> ls /dev/disk/usb

… dd if=haiku-r1beta4-x86_gcc2h-anyboot.iso of=/dev/disk/usb/0 bs=1M
dd: error writing ‘/dev/disk/usb/0’: Is a directory
1+0 records in
0+0 records out
0 bytes copied, 2.64235 s, 0.0 kB/s

The pnth to the usb is not complete. You need something ending in “raw” (usually …/usb/0/raw)

I just tried it again after using DriveSetup on the USB stick…but still got a 0.

Going to reboot using EasyOs to wipe the stick clean and try again…

well…this is a puzzle.
Deleted the parition…and still get a 0
…so tried a different USB stick…and again got a 0.

Im going to go and look at other options and come back tomorrow with any findings.

Might try burning a new Nighty CD …and maybe get that working.

well tried a new nightly…and almost got a working CD…to the point where all the icons light up, then nothing…no cursor.

seems some files are failing to load so will do another download and burn another CD.

before burning another one maybe verify the old one is burned correctly, if it is then the error is somewhere else.

You can also verify the previous download with a shasum to see it was downloaded correctly.

When the CD is burnt, I letting the process verify the process was completed correctly.

Im having issues with doing the sha256 check - get different numbers…but I may be doing it wrong ie:
shasum -a 256 ~/Downloads/

shasum -a 256 ~/Downloads/

just tried unzipping the iso to see if that helps:
shasum -a 256 ~/Downloads/haiku-master-hrev57801-x86_gcc2h-anyboot/haiku-master-hrev57801-x86_gcc2h-anyboot.iso

Ive not used shasum before…seems less trouble with other checksums.

Can anyone gget a matching result ? …if so could they please tell me how…this is with a nightly 32bit download.

This file should contain the shasum of the actual file, read it to compare it with the returned sum of the other file.

Im not sure how I open that…or do I just remove the sha256 from the name, making it a zip file ?

aha - using an old iMac for downloads, and had to install required software…and the result:

…so the download is correct.
Next stage - copy to an old iBook to make the CD.
(By the way Ive moved on from trying to make a 32bit USB stick on a 64bit Haiku-os - just wont work…so focus is on making a bootup CD using a nightly as its less than 700mb.)