Problems to make a full USB installation

Dear users,

I made a complete Haiku installation to an USB key of 8GB. As I just intend to create simple programs, I thought it was enough. I had to do several attempts to get it correctly installed because I used to take the USB key “too soon” (well, the installer told me that it was ready). It must be the synchronization time… Fair enough. The problem is that I regret the choice of an 8GB key and I want to repeat the process on a 16 and a 64 GB ones of different brands. Unfortunately, the process fails. The latter that I remember starts correctly but at some point the icon of the USB key changes from the standard one to a kind of wardrobe or cupboard. I say “the latter that I remember” because I have made many many attempts, even waiting a lot of time and explicitly running the “sync” command. Do you know what is going on? Have you ever experienced this kind of problem?

Kind regards

PS: I have tried from my correct working USB one to the new one, but also from a virtual machine in another PC. Besides, I have even tried to copy the files manually with a “cp -r …” command.

I may be wrong, but it may be related to the fact USB 1.1, USB 2.0 and USB 3.0 standards difference include the difference in some electric aspect (frequency / voltage / etc - I really don’t know), which implies the limitation of the space that can be used with some specific USB standard. It may happen that 16GB or 32GB USB key can only be effective written over USB 3.0 and thus can only boot from USB 3.0 port. However, Haiku currently has some limited USB 3.0 support, and so Haiku may fail booting from USB 3.0 port.

Could you explain more about the process you used to create/initialize a haiku partition?
One good advice: stay away from DriveSetup when you create your partition use some other tool for that, and use DriveSetup only to initialize the partition, and report back.

Yes. USB devices downgrade to the common version of the spec. And it was perfectly possible to use terabytes HDD with USB1 already.

1 Like

If you have problems with DriveSetup, please create a bugreport.

1 Like

Mm, that sounds logic. I’ll do some more testing next weekend. I will pay special attention to the USB key that I pick.

Kind regards

Most of the times I used the installer (I suppose it’s the same as Drive Setup). I have also used Drive Setup directly some other times. Regarding the steps I follow, they are mainly those described in the installation guide but to an USB key.

As I said, I’ll do some more testing next weekend. Kind regards.

The Installer and DriveSetup are in fact two different applications. Installer does the installation (the copy of system files) and DriveSetup allows to manage disk partitioning and file system initialization.

But while using Installer you will find there a button that allows to launch DriveSetup.

The OP said:

We “old haiku users” know that 8 GB is enough for what he intends to use it for.
So it’s only natural for me suggesting him to use another tool to partition his drive, knowing that DriveSetup tends to create smaller partitions, because it has a bug which he as a new user doesn’t know about.
i was just trying to help him to avoid getting frustrated
As for the bugreport there already at least 3 that i know of.

1 Like