Problems booting to Haiku nightlies on usb-key

I’ve used Haiku for more than three years on my EeePC901 netbook and never had any problems re-installing or upgrading the Haiku version from usb-key (no optical drive available).
Now I have Haiku R1A3 installed and working fine and I very much wanted to try out the newly ported wpa_supplicant which I understand is only available in nightlies from r42778 on.
However, in all of the recent nightlies that I’ve tried (r42778 to r42804), the usb-key boots only to a black screen.
I have tried many alternatives to correct this (two different usb keys, burnt the usb-key from Linux and from Haiku, downloaded and anyboot.xz) but all gave the same result.
In addition, using the same keys on a Dell E520 desktop gave the same no-boot problem (boot only to black screen) until today when I tried out r42804.
Now the usb-key boots perfectly to the Haiku Desktop on my Dell E520 but still does not on the netbook.
I have also tried several fail-safe video modes on the netbook, but none proved successful.

Specifically, during the boot from usb-key with the most recent nightlies, although the seven icons appear on the bootsplash page, the word HAIKU is absent (although this didn’t stop r42804 from booting on my Desktop).
Then, on the netbook, after the rocket icon turns red, the screen turns black with an ill-defined white interior that slowly fades to black, leaving the whole screen black.

Note that using the very same techniques, today as a check, I burnt R1A3 to one of the same usb-keys and found that this booted perfectly on the netbook (as it has done previously).

Has anybody any clue as to what might be happening here?

I have no clue either, but I know that the Oct. 6th build will not boot all the way to desktop on my Laptop. I have a 16 gig stick I have been booting Haiku from ever since Alpha 3. That and my 80 gig external hard drive no longer boots on my HP laptop, but works fine on my generic GigaStrand custom PC. Also, the said build will stall in VirtualBox 4.1 with a Kdebug white screen.

I suspect the App Server is having issues with certain accelerants, but I could just be wrong. Beta beta beta come soon!

This is probably the issue, I know it efects my eeepc:

Try safe mode video … the screen will be distorted at 800*600, but at least the desktop shows.


I am in a very similar situation (I have been using Haiku in my Dell Mini 9 Netbook since more than 2 years - I have bought the Mini 9 at the end of 2008).
Recently I have problems booting from USB-key starting with r42778 until r42801 (the last tried).
I get no desktop at all (after getting all the icons sequence during boot OK) but instead I see the screen in one single color and cycling like this: all white, all red, all green, all blue, black-white horizontal gradient, black-white vertical gradient).
It looks like some kind of graphics card internal test.
I have tried the video fail-safe mode and boot is OK with 800x600 resolution (but it is really sad to see the distorted screen on my Netbook…, and 800x600 in a 9 inches screen is really small)
Note that usually (for releases before r42778) I need to tweak the boot a little using some safe-mode options: no add-ons, no ACPI, no APM (and boot is also quite random too - sometimes I need to try the boot many times before getting a good one)
My Dell Mini 9 has an integrated Intel GM950 Graphics card.
I have been using these same nightlies in another Laptop (Acer TravelMate 4280) and never got any kind of problems during boot, no safe-options mode tweaks (always booting from USB-key);(well almost never - sometimes I got a kernel panic white screen during boot, but this is very rare with the Acer). The Acer has an integrated Graphics card based on Nvidia GPU (GeForce family). Booting r42801 in the Acer and running devices: Display Controller -> nVidia Corporation G73 [GeForce Go 7600].

I hope this can help somehow (it turned out a bit lenghty comment too, sorry :wink:

paulfxh, rbtdi (and ddavid123 too, I guess), bbjimmy is probably right, all the issues you are experiencing seem to be related to the “intel_extreme” driver changes from r42742.
You have 3 choices:

  1. Wait for the ticket #8001 to be fixed (it won’t take long hopefully, I too am interested in testing the wpa_supplicant on my EeePC… and if everything goes fine, Haiku goes officially main on it! =D)

  2. Use a workaround: Install one of the latest builds into your “PCs with problems” (using VESA, safe mode or whatever is needed to get it running), take the first nightly before r42742 (on there’s r42734), burn it to usb, boot off it and, if the video driver is working right, copy that revision’s “intel_extreme” driver (I don’t remember exactly where it’s located ATM) over the one of your installed Haiku build. I’m not 100% sure it’ll work, but it’s worth a try.

  3. The fugly VESA 800x600…

Great! I’m glad to hear it worked, guys!

Modularity <3

PS: On a second look, the “culprit” commit only modified the accelerant’s code, so yes, it’s safe to assume (as you pointed out) that it’s the accelerant, and not the driver, to be faulty in the newest nightlies.

Hello Michael,

thanks a lot for your suggestions!

I would avoid option (3) altogether (it is real ugly… ;-).
I will try option (2) - I have a coming weekend for that … :wink:
In case option (2) doesn’t work there is always option (1) or similar.

Concerning the driver changes from r42742 (I don’t remember to have tried this release however) I have noted a funny/strange thing: everything was working OK (video/graphics driver I mean) until r42771 included (I have tried many of the previous nightlies including r42747, r42751, r42460, r42768 and finally r42771 and none of them gave problems with the video in my Dell Mini 9. Problems started with r42778 onwards - strangely enough, going back from r42778 to r42771 and r42760 these versions no longer worked ?!). At some point I was/am suspecting of HW problems/fault in my Dell Mini coming up … :frowning:
By the way R1A3 works really well for me.

I will let you know about my findings concerning option (2)

Best regards to you all!
Have a nice weekend!

IIRC : Since Alpha3, the build system generate the Haiku logo only for official releases (nightly builds are not).

Hello Michael, everybody else with similar video driver problems,

I have already tested your option (2) and it WORKED!

I did not use r42742 but I am using the parts from Haiku R1A3 (it is as far as I remember earlier than r42742 anyway) which for me works really fine (I wanted to use a version that I know is working good on my Dell Mini 9)

I booted from the USB-key with r42807 (the latest) with video safe-mode 800x600 32 bits color (this works for me); this time I kept user add-ons option and removed ACPI and APM options as usual (that apparently hang the boot process in my Dell Mini 9)
then I mounted the USB-key with my R1A3 version and proceeded with copying files as below.

The procedure is fairly simple:

a) find the “accelerant” (in my case intel_extreme.accelerant) under /boot/system/add-ons/accelerants in the good Haiku version (R1A3 in my case) and copy it in the same directory of the “bad” version (in my case r42807) - or if you prefer delete the bad one, or even better rename it to something useful (I appended _NEW to intel_extreme.accelerant, which indeed is new but faulty - I will keep this for testing the video screen with cycling colors and gradients :wink:

b) find the “driver” (in my case intel_extreme) under /boot/system/add-ons/kernel/drivers/bin in the good Haiku as in (a) above and copy it to the bad (new) version - renaming/deleting etc again as in (a).

Close everything, shutdown and on the next boot everything should be fine.
In my case it seems that keeping user add-ons is OK (or better).

NOTE: since I have changed both files (driver and accelerant) I don’t know which one was faulty, may be both but since the sizes of the driver files are the same (old good compared to new bad) and the accelerant have different sizes I suspect strongly of the accelerant.

I hope this can be useful to others with similar video driver problems.

Thanks a lot again!
(I still have some other issues with nightlies but for now I am quite happy!)

Best regards and good Haiku!

Roberto B.

Thanks to MichaelPeppers for this suggestion, a variant of which worked for me.
I say variant because, on the EeePC901, I was completely unable to boot any recent nightly to a usable Desktop in spite of trying all failsafe video modes including in full safe mode.
However, by booting to Haiku R1A3 and mounting RW the usb-key containing r42804, I was able to delete the files /system/add-ons/kernel/drivers/bin/intel_extreme and /system/add-ons/accelerants/intel_extreme.accelerant from the usb-key and replace them with the equivalent files from R1A3.
Now, the usb-key booted without problem on the EeePC901.
Note that I initially only replaced the /system/add-ons/kernel/drivers/bin/intel_extreme on the usb-key with that from R1A3 and this did not boot (well, it booted but only to a black screen).
It was only when I additionally replaced the /system/add-ons/accelerants/intel_extreme.accelerant file that I was able to boot without problems.
This perhaps confirms the suspicion of rbtdi that the faulty file is actually the accelerant rather than the intel_extreme driver.

Edit: Just to add that after installing r42804 to SSD on the EeePC901, WPA2 wireless works fine on this machine after installing wpa_supplicant. Wireless card is Ralink 2860

As I regularily use my Samsung NC10 with GMA950 to test Haiku nightly builds these boot problems made me wonder if my netbook was also affected. I’ve run an unmodified r42835 gcc2hybrid build from SD card and haven’t encountered any problems regarding graphics so far. Do you use an external monitor or are there different types of GMA950 chips around?

I have the same Samsung NC10 and I also end up with a black screen with current images. Devices shows me two Display-Controllers, by the way:

  1. Intel Corporation Mobile 945GME Express Integrated Graphics Controller
    id: 0x27ae
    subtype: 0x0
    class-info: Display controller (VGA compatible controller)
    pci/function: 0

  2. Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller
    id: 0x27a6
    subtype: 0x80
    class-info: Display controller
    pci/function: 1


No external monitor in use on my EeePC 901.

My gfx cards are the very same as Humdinger’s as shown here
listdev | grep Graphics
device 27a6: Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller
device 27ae: Mobile 945GME Express Integrated Graphics Controller

Today I tried to boot both r42849 and r42860 from usb-key and got exactly the same performance as with the earlier nightlies (boot to black screen).
In both cases,however, just replacing /system/add-ons/accelerants/intel_extreme.accelerant on the usb-key with the equivalent file from R1A3, completely remedied the problem.
IOW, nothing has changed for me.

I have had the same issue with usb drives and sticks not booting! The problem was the partition was not set as “active”. So I booted into Linux and opened :Gparted". Once there I deleted the current Haiku labeled partition on the usb stick/drive and created and formated a new FAT 32 filesystem. Then I changed the flag to boot and applied.

Now my Haiku usb stick/drive boots just fine, except on my main 3 year old PC. For some reason it still won’t boot from usb stick/drive! It just restarts again and again. I think it is a bios thing even though I have enabled it to boot from usb. I have booted Linux from usb many times!

Hello eveybody,

I too was having boot problems from a USB-key using my netbook Dell Mini 9 (see my previous postings in this forum).

The other day I downloaded a new nightly release (r42847) and instead of using the Dell screen I connected an external LCD monitor to the VGA (blue) connector. The monitor is a Philips model (Brilliance series, 20 inch, 4/3 format, 1600 x 1200 native resolution at 60 Hz and 32 bpp) - I don’t remember right now the exact model number.

To my surprise the netbook booted normally from the USB-key with the Philips LCD (1600x1200 and other screen settings correctly detected) while it still does not boot from the USB-key with the Dell 9 inch screen - it shows the same sequence of colors as mentioned in my previous posts.

At this point my suspect is that the problem might be related specifically to screen resolution and their parameters correct detection during boot (by means of DDC I suppose). It looks like the communication between the Dell LCD screen and the graphics chipset/driver is not working OK as with the external Philips…:frowning:

I just wanted to let you know my new findings concerning screen faults during boot (from USB-key)

PS.: the Dell graphics card on my Dell Mini 9 (as seen by “Devices” under Haiku) is a Intel Mobile 945 as in point 2. from Humdinger’s post

Best regards

Roberto B.

It seems your USB key have an old MBR (Alpha3 has a new one).
You have to install a new one from the Alpha3 anyboot image.
1 : download the Alpha3 anyboot image file (anyboot.img)
2 : execute the following command:

dd if=/anyboot.img of=/dev/disk/usb/…/…/raw bs=440 count=1

NB : adapt the “of” parameter to your USB device path.

Hello again,

a quick update concerning my previous post.

The behavior is the same when booting r42860 from USB-key:

a sequence of colors/patterns (and no Haiku desktop) when booting using Dell’s screen and OK with fully functional Haiku desktop with external monitor and the Philips optimal settings of 1600x1200 resolution correctly detected. [the sequence of colors/patterns of the whole screen goes like this: black, white, red, green, blue, light gray, dark gray, horizontal gradient (black to white from right to left), vertical gradient (black to white from top to bottom), black, …repeat]

The Philips LCD monitor model is: Brilliance 200P.
The graphics card on my Dell Mini 9 netbook is the same as given by data from Humdinger and from paulfxh posts.

(currently I am using only the external Philips monitor - for size and convenience, but at any rate I will be testing the next nightlies to check when they start working again on my Dell - without having to adapt the accelerant file, that is.)

I hope this can be useful.

Best regards

Roberto B.

Well, this surprised me, too so I tried it out for myself using my EeePC 901 hooked up to an external monitor (Acer X223HQ with 1920x1080).
Now I booted to a usb-key with r42804 WITHOUT having swapped out the intel_extreme.accelerant file and, amazingly, the Acer monitor showed the Haiku desktop perfectly at 1920x1080 resolution (60 Hz) (with nothing but a few flashing lights on the EeePC screen).
However, if I reduced the screen resolution to 1152x864 or 1024x768 (still 60HZ), a perfect Haiku desktop showed up on BOTH monitors.

Go figure.

Hello paulfxh,

I forgot to mention one thing concerning my hook-up with the external monitor (and this came to my mind reading that at some point you can see BOTH screens working):

when I manage to boot with the external monitor (at 1600x1200, and as far as I remember with smaller resolutions too, up to 1024x768) I see just the external monitor, the screen on my Dell is always BLACK (i.e. switched off) - and I never managed to see both working together (and with the same hook-up running Ubuntu Linux, I can see BOTH screens…) - I am afraid I’ve got some problems with the external monitor management on my Dell (you know there is a key-combination to select/de-select external monitors).

On the other hand, I always managed to hear (audio part now) BOTH internal speakers on the Dell and external amplified speakers connected to the headphones output (in this way it turns out a “sort of” bi-amp set-up since frequency response of the internal speakers and that from the external ones is slightly different and listening to both at the same time (with separately adjustable gains) enhances the sound a bit.

At any rate, at this point it looks to me that the “old” intel accelerant from R1A3 is still a better choice after all.

Best regards,

Roberto B.

The display controllers of my Samsung NC10 seem the same as humdinger’s. My NC10 is a first generation model (KA05DE) with a 10,2’’ display - later models got a 10,1’’ display. Could this explain the different behaviour?