Problem with Tray


i have a question about deskbar/tray - as you may see in the screenshot of my desktop, there are a lot of ? ? ? ? in the Tray. They start to appear when i open some apps, like Telegram, Otter browser and others…

Is there any way or option to disable them ?

Hi and welcome! About Otter, yes, there is a way:

  1. type about:config in the address box.
  2. filter by tray word. You will find a value named EnableTrayIcon.
  3. just change the value to No

Not sure about Telegram. I don’t have it installed.

1 Like

You can disable the tray for most Qt applications through their Preferences. This is a bug in Haiku Qt code.

1 Like

In case you have enabled it, try to disable “Localized application names” in the Local preflet.

There is a ticket about this on HaikuPorts:

Unfortunately it has not really been investigated yet.

1 Like

Thanks for your answers. I’ve changed locale from Lithuanian to English and now Kotatogram(Telegram client) is working good. No more question marks. :slightly_smiling_face:

So far everything is almost perfect for old time Linux user with Haiku. Maybe someone could give a hint or some handbook link for Haiku command line tools? For Linux commands like “lsmod”, “dmesg” or “lspci”

Hi! For the lspci command, you need to install the pciutils from HaikuDepot.

1 Like

Also, there you have aditional information about the command line applications that cames with Haiku:

Notice that the previous link only include the default command line applications that are include with Haiku. There are also aditional cli apps in HaikuDepot.

1 Like

It is not necessary to change the localization to English. It is enough to disable this option.


listdev and /var/log/syslog.
There is no lsmod equivalent

1 Like

The Welcome page has some useful tips to get infos for bug reports. There’s a section on Hardware/Driver bugs that should be pertinent to your question.