Problem with starting VMWare image

Hi all,

I just downloaded a nightly VMWare build and I have VMWare Workstation under Windows, but it fails to start Haiku using the provided VMX file. The error when starting the virtual machine is: “File not found: haiku-pre-alpha-gcc4.vmdk”

I updated the VMX file so the VMX and VMDK file names are the same and correctly entered in the VMX file. What else can be the problem?

Below is my VMX file:

#!/usr/bin/vmware .encoding = "windows-1252" config.version = "8" virtualHW.version = "3"

MemAllowAutoScaleDown = "FALSE"
MemTrimRate = “-1”

uuid.location = "56 4d 20 2e e7 51 21 3a-cf 1f 8c a4 85 aa 04 9b"
uuid.bios = “56 4d 20 2e e7 51 21 3a-cf 1f 8c a4 85 aa 04 9b”

uuid.action = "create"
checkpoint.vmState = “”

displayName = "Haiku - prealpha - gcc4"
guestOS = "other"
memsize = “256”

ethernet0.present= "true"
ethernet0.startConnected = "true"
ethernet0.virtualDev = "e1000"
ethernet0.connectionType = “bridged”

serial0.present = "true"
serial0.fileType = "file"
serial0.fileName = "haiku-serial-port.txt"
serial0.tryNoRxLoss = “FALSE”

usb.present = “FALSE”

sound.present = “FALSE”

scsi0.present = “FALSE”

floppy0.present = “FALSE”

ide0:0.present = "TRUE"
ide0:0.fileName = "haiku-pre-alpha-gcc4.vmdk"
ide0:0.deviceType = "disk"
ide0:0.mode = "persistent"
ide0:0.redo = ""
ide0:0.writeThrough = "FALSE"
ide0:0.startConnected = “FALSE”

ide0:1.present = “FALSE”

ide1:0.present = “FALSE”

ide1:1.present = “FALSE”

ethernet0.addressType = "generated"
ethernet0.generatedAddress = "00:0c:29:aa:04:9b"
ethernet0.generatedAddressOffset = “0”

tools.remindInstall = “TRUE”

extendedConfigFile = "haiku-pre-alpha-gcc4.vmxf"
virtualHW.productCompatibility = "hosted"
tools.upgrade.policy = “manual”

fileSearchPath = “G:\Virtual Machines\Haiku;.”

policy.vm.mvmtid = "52 34 74 ac 5a ed 7e b3-5e 87 51 55 f5 2d 84 51"
policy.vm.managedVMTemplate = "FALSE"
policy.vm.managedVM = “FALSE”

Make sure it has the right filename, and is in the right location. (I assume G:\Virtual Machines\Haiku is your specified path).

I’ve also heard some people claiming that certain versions of VMWare fail to load the vmdk files generated by Haiku’s build system - in which case I would alternatively recommend grabbing one of the .raw files and using qemu-img to convert it to vmdk.

  • Urias

I can confirm that this does not work (error finding correctly-named-and-located-vmdk) on a freshly installed version of VMWare Player on Windows XP SP3.

Also just re-confirmed with VMWare Player 2.0.2 build 59824 and VMWare Workstation 6.0.2 build-59824 on this laptop (yes, my version numbers are suspicious.) On WinXPSP3. It allows you to then browse for the vmdk. Double-clicking on the exact vmdk in the browse dialog will produce the same message stating it couldn’t find it.

Please also try with the GCC2 version - I actually seem to recall someone in the IRC channel claiming that one worked, while the other did not.

GCC2 version [] works as expected. It is just the GCC4 version that fails.

I also experienced the same problem with VMWare player and XP SP3. So I am now using VirtualBox for running Haiku image.

For me, there is a bug in the vmdk file. I had to convert it with a tool I wrote some time ago :

I suspect VMWare to be a bit ticklish when it reads the vmdk-header. (the data are correct)
you may open a ticket…

N.B. it was the GCC4 disk image.

Just want to let you know that I have the exact same problem with the GCC4 version.

I’ve solved this problem by downloading an ancient version of Haiku (I used vmhaiku.r28837), unpacking it, and physically replacing the hard disk file with the hard disk from the new version. The hard disk image file with Haiku I want to run will overwrite the file from older, r28837, version. Of course, the file should be named exactly the same as the image file from r28837, which will be overwritten. (Hard disk image file is noticeable due to its size).

This will work for both GCC2 and GCC4 versions of Haiku. Tested personally.

Here’s my explanation in Russian, which can be translated to every language using Google Translator, in case additional explanation is needed.

I think instead of a workaround, we do need to fix the cause :slight_smile:

Can you file a bug in Trac?