Problem with gmp-6.1.2-3x86_64.hpkg

I have recently reinstalled Haiku, and now find I can’t install important packages using Haikudepot. These include Libreoffice, Krita, Otter, and several others.
In every case the installation fails saying that gmp-6.1.2-3x86_64.hpkg does already exist.

I can’t find any reference to this either on here or in the bug tracker. Has anybody come across it, and is there a fix, or should I just report a bug?

It happens with recent nightlies from about a week ago. In each case I have been installing to a newly created BeFS partition on two different laptops.

I don’t know if it’s similar but my 2 cents.

I installed latest nightly (64bit) a couple of days ago and initially in Haiku Depot I was seeing only very few apps with all major ones missing. I think I did a “refresh repositories” and then everything began working OK and was able to install everything. Oh, before that I attempted to install another small utility and I remember HaikuDepot begin installing much more stuff than anticipated, like catching up…

An important detail: I installed the nightly over a beta2 partition by maintaining my data.

1 Like

Depending on the error message, it may be this issue:

1 Like

It’s not quite the same but it could be connected.

This is the full error message:

Fatal error occurred while instaling package calligra: failed to commit transaction: The to be activated package gmp-6.1.2-3x86_64.hpkg does already exist.()

My experience was a bit different but, like you, I did notice a lot of files being downloaded.

Go to /boot/system/packages, you will see that indeed the package gmp-6.1.2-3x86_64.hpkg exists
Then go in /boot/system/packages/administrative you will see a file named activated-packages, if you open it, you will see that, probably because of the bug mentioned, this package isn’t in the list.
While devs are investigating, here’s a workaround to solve the problem.
Go in /boot/system/packages/administrative and suppress the file named activated-packages
(Since it is a system folder, you will have to press Shift key to enable deleting).
Reboot, in absence of that file the package daemon will consider that all files in /boot/system/packages are to be activated and should recreate the activated-packages file with a correct list.


Well, that worked a treat! Many thanks.

Can I assume that this is a known issue, or should I submit a bug report?

Yep, it’s a known thing but there’s something you can do.
People are not used to it yet but now you can vote for your “favourite” bug so I suggest that you vote for the above one mentioned by waddlesplash.

1 Like

Thanks again.

I must have registered on the bug site a while ago because it knows my email address but wants to know my username too, and of course I have forgotten it. It’s not the one I use on the forum, for some reason.

I must now search through a million emails. :frowning:

Found it on the third go, thankfully!

Voted! It’s now equal most popular ticket.

Noob to Haiku here, though with several years experience of Puppy Linux under my belt. (Used to what the rest of the community tends to think of as ‘quirky’ ways of doing things, so I feel right at home here!) :grinning:

I was just about to post on this issue myself, but I’ve been saved the need to.

Followed the instructions; deleted the admin-packages file, re-booted, opened Haiku depot, refreshed the repos, aaaand…stuff installs now.

Thanks, Starcrasher. Clear, straightforward instructions work a treat, every time.

(Been wanting to try Haiku for a long time, but for some reason my old hardware just wasn’t having it. My new HP desktop, however, seems quite happy with it all; so far, I’m liking what I see.)

Keep up the good work, guys.

Mike. :wink: