Problem resolving host name with WebPositive

WebPositive works for reading a page of file:// designation but not http://. I get the error message “Couldn’t resolve host name”. I am using a router. Any suggestions would be appreciated.

I am doublebooting with Kubuntu using grub. The grub setup worked perfectly.


Check Network Preferences and see if your network card is listed.

If it is, try setting a static IP and manually enter your gateway and dns IPs — see the Kubuntu network set-up if you don’t know the IPs for these.

If not, what kind of network card do you have? It may not be supported in Haiku.

Good Luck

I am having the same problem running Alpha 3 in VirtualBox on OSX. Network preferences has nothing listed under devices but a network controller does show up in Devices and VirtualBox shows an active internet connection going to the VM.

The network card is listed, and I have access to the router using its internal IP address and can view and modify its parameters. No success with the suggestion to use static addresses – still get “couldn’t resolve hostname” when I try to get any website. Attempting to connect to a page using its IP address directly instead of its hostname got error “couldn’t connect to server”. The DNS addresses in Haiku are the same as shown by my router and seem to be correct.

How would I find out if there were any hardware incompatibility?

Still wondering.

How would I find out if there were any hardware incompatibility?

I have no idea about possible quirks of VirtualBox under MacOS, but being a virtual machine should mean that there can’t be any hardware incompatibilities. Provided you choose to virtualize Haiku supported hardware. Have a look at this insanely long page about running Haiku in VirtualBox. Right at the bottom it deals with network issues. It really should work, if you choose those exact settings.


At present the Devices app merely enumerates all hardware. IIRC it doesn’t say anything at all about drivers or whether or not a device is working as expected or even supported. Such functionality will likely be added at some point in the future.

If you want to see which network interfaces are available and supported by a driver, you can check the Network preferences or the Terminal command ‘ifconfig’ or look at the filesystem entries below /dev/net.

VirtualBox may offer a choice in what network device (NIC) it provides to the virtual machine. You may be able to get Haiku alpha 3 to work with one of the alternative devices that VirtualBox provides.

Bug reports are always more meaningful when tested with a recent nightly image. Available here:

If you can ping your router, or access its web interface, from Haiku, then your network card is supported.

DNS name lookup appears to be the issue. I can’t say why it fails in your case, but I suggest that you try setting up your router to do DNS forwarding (serving DNS to the LAN) and set up Haiku to use the router (gateway) IP number for DNS lookup.