Problem installing on a ThinkCentre M600 (usb error?)

Hi, I try to install on a Lenovo ThinkCentre M600. It hangs up at the rocket step. Starting in Safe Mode works. I have attached a debug log screenshot with the problem. This message with “usb hci 0” repeats endlessly. The box has 4xUSB3 and 2xUSB2 ports. I have already tried to disable XHCI without success. Then, unfortunately, the mouse & keyboard no longer works.
Thank you very much.

1 Like

Is this the beta release? If so, please retest with a nightly build and see what happens.

OK, yes it was with the beta version and I have the same problem with haiku-master-hrev57275-x86_gcc2h-anyboot.iso

On a think center m800, I had to either disable io-apic or ACPI. Can’t remember. Try narrowing it down to one of those.

Both actually helps from the boot menu… but how can I make it permanent, with which entries? So as described here? → Disabling components of packages | Haiku Project

About the other solution again… the version haiku-master-hrev57275-x86_64-anyboot actually boots normally (without using the boot menu). But unfortunately the version does not recognize my built-in SSD! :wink:

1 Like

You can disable either acpi or io-apic by editing the file: /boot/home/config/settings/kernel/drivers/kernel.

Just un-comment either or both of these lines:

#disable_ioapic true

#acpi false


Oh. Is it Nvme? Mine had no trouble with the SATA ssd.

I would see if you only need one of those safe mode options.

With commenting out the line

#disable_ioapic true

it works now. Thanks a lot!

The small box has the following technical data:

Processor Intel® Celeron N3000 1.04 GHz
Working memory 4 GB RAM
Hard disk 16 GB M.2 SSD
Graphics card Intel HD Graphics

… which is actually quite enough for me. Especially because the full resolution (QHD 2560x1440) of my monitor is also supported (and not just VESA). GLTeapot does just under 100 FPS.


What I wanted to say, the way the debug logs build up, so not the newest line in the last line and the rest shifted one line up, but the next line always one line down to the end of the screen and then back to the beginning… very cool! Does this kind of text “scrolling” have a name?