Problem booting Haiku on iMac 2019

Hi !

I´m searching many days but did not a solution.
I am using a iMac 19,2 from 2019.

Normally I use Linux for my daily business.
Now I have tried Haiku on my laptop for a long time and its like… year - I like it :slight_smile:

Here is what my problem is:
I create a installation media (tested all things: partition with direct dd of image, live boot from usb, efi boot from external hdd, formated internal hdd with efi partition and tried to boot…)
All the time I try it, I get only a black screen.
I can choose the Haiku EFI-boot via ALT on startup.
After that - nothing.
No logo, no splash - just black.
If I wait about 5 minutes, the iMac simply reboots.

I have tried do blacklist the intel_extreme and many other drivers, without success.
I can´t get in the bootloader with shift or space bar, get only black screen.

I have also installed Haiku from my laptop to external hdd and booted from there same thing.
Also I have installed Haiku via VirtualBox and direct access to the partition on the internal hard drive.
In Virtualbox it boots fine and I can disable all drivers during boot.
But, if I really boot it…
…I must not tell it…

I have currently no idea what to do, because I don´t get any error or some other messages.

Some ideas ?
I have currently installed Linux and can test anything.

Thank you for helping (any sorry for my really bad english )

One word, drivers. Not too many, not enough. Blacklisting drivers does nothing to solve a lack of drivers for that hardware.

Try to chainload haiku_loader.efi via rEFInd bootloader.

@Diver: Already tried it.
Yesterday I have removed all usb devices and wiped fully the internal SSD drive to MBR and GPT.
Also resetted the NVRAM of the iMac.
I always getting the same result: nothing.

I think it is as @BlueHorse speak: lack of drivers.

Ah, I must say sorry !
I have a brand iMac from the beginning of 2021 (Intel machine !)
In Linux I get the message, it´s a iMac 19,2 from 2019 but thats incorrect.

Should I post my full hardware details to get the drivers working ?

If yes, what infos did you need ?
Is the output of “lshw” enough:

H/W-Pfad             Gerät        Klasse         Beschreibung
                               system         iMac19,2
/0                                 bus            Mac
/0/0                               memory         16GiB Systemspeicher
/0/0/0                             memory         8GiB SODIMM DDR4 Synchron 2667 MHz (0,4 ns)
/0/0/1                             memory         8GiB SODIMM DDR4 Synchron 2667 MHz (0,4 ns)
/0/4                               memory         1MiB BIOS
/0/1d                              memory         384KiB L1 Cache
/0/1e                              memory         1536KiB L2 Cache
/0/1f                              memory         12MiB L3 Cache
/0/20                              processor      Intel(R) Core(TM) i7-8700 CPU @ 3.20GHz
/0/100                             bridge         8th Gen Core Processor Host Bridge/DRAM Registers
/0/100/1                           bridge         6th-10th Gen Core Processor PCIe Controller (x16)
/0/100/1/0                         bridge         Advanced Micro Devices, Inc. [AMD/ATI]
/0/100/1/0/0                       bridge         Advanced Micro Devices, Inc. [AMD/ATI]
/0/100/1/0/0/0       /dev/fb0      display        Vega 12 [Radeon Pro Vega 20]
/0/100/1/0/0/0.1                   multimedia     Advanced Micro Devices, Inc. [AMD/ATI]
/0/100/12                          generic        Cannon Lake PCH Thermal Controller
/0/100/14                          bus            Cannon Lake PCH USB 3.1 xHCI Host Controller
/0/100/14/0          usb1          bus            xHCI Host Controller
/0/100/14/0/5                      bus            USB2.0 Hub
/0/100/14/0/5/1                    input          USB Gaming Keyboard
/0/100/14/0/5/2                    input          GD32 custom HID in FS Mode V1.06
/0/100/14/0/a                      multimedia     USB Audio Device
/0/100/14/0/d                      multimedia     FaceTime HD Camera (Built-in)
/0/100/14/0/e                      input          YubiKey OTP+FIDO+CCID
/0/100/14/1          usb2          bus            xHCI Host Controller
/0/100/14.2                        memory         RAM memory
/0/100/16                          communication  Cannon Lake PCH HECI Controller
/0/100/17                          storage        Cannon Lake PCH SATA AHCI Controller
/0/100/1b                          bridge         Cannon Lake PCH PCI Express Root Port #17
/0/100/1b/0                        storage        NVMe SSD Controller SM961/PM961/SM963
/0/100/1b/0/0        /dev/nvme0    storage        APPLE SSD SM0512L
/0/100/1b/0/0/1      /dev/nvme0n1  disk           500GB NVMe namespace
/0/100/1b/0/0/1/1                  volume         58GiB EFI GPT partition
/0/100/1c                          bridge         Cannon Lake PCH PCI Express Root Port #1
/0/100/1c/0                        network        BCM4364 802.11ac Wireless Network Adapter
/0/100/1c.1                        bridge         Cannon Lake PCH PCI Express Root Port #2
/0/100/1c.1/0        enp6s0f0      network        NetXtreme BCM57766 Gigabit Ethernet PCIe
/0/100/1c.1/0.1                    generic        BCM57765/57785 SDXC/MMC Card Reader
/0/100/1c.4                        bridge         Cannon Lake PCH PCI Express Root Port #5
/0/100/1c.4/0                      bridge         DSL6540 Thunderbolt 3 Bridge [Alpine Ridge 4C 201
/0/100/1c.4/0/0                    bridge         JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018
/0/100/1c.4/0/0/0                  generic        JHL7540 Thunderbolt 3 NHI [Titan Ridge 4C 2018]
/0/100/1c.4/0/1                    bridge         JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018
/0/100/1c.4/0/2                    bridge         JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018
/0/100/1c.4/0/2/0                  bus            JHL7540 Thunderbolt 3 USB Controller [Titan Ridge
/0/100/1c.4/0/2/0/0  usb3          bus            xHCI Host Controller
/0/100/1c.4/0/2/0/1  usb4          bus            xHCI Host Controller
/0/100/1c.4/0/4                    bridge         JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018
/0/100/1e                          communication  Cannon Lake PCH Serial IO UART Host Controller
/0/100/1e.1                        communication  Intel Corporation
/0/100/1f                          bridge         Q370 Chipset LPC/eSPI Controller
/0/100/1f.3                        multimedia     Cannon Lake PCH cAVS
/0/100/1f.4                        bus            Cannon Lake PCH SMBus Controller
/0/100/1f.5                        bus            Cannon Lake PCH SPI Controller
/0/1                               system         PnP device PNP0c02
/0/2                               system         PnP device PNP0b00
/0/3                               system         PnP device PNP0c02
/1                                 power

The big issue with Mac hardware is it really isn’t “pc compatible”, meaning you have to add a lot of support code for poorly documented things which are non-standard and Apple specific.

A good example (which is likely relevant for your hardware) is the T2 chip. Haiku would need to “unlock” access to the keyboard via the T2 chip. The T2 chip prevented Linux from booting on these Mac’s for a year or two.

I’m not saying it can’t be done… but the hardware is expensive and the Mac doesn’t have traditional serial ports for kernel logs… so a black screen is a black box to debug. is one such patch I proposed which might help, though I never got any improvement on the one Apple laptop I have locally.

tldr; if you’re not willing to debug this one (or find someone to debug it for you with similar hardware), you might be better off emulating Haiku from OS X.

I know that answer isn’t satisfying, but trying to be realistic :slight_smile:

1 Like