Printer Ricoh SP330DN works ! How to print PDF files with it

Hello everyone,

Just a report of the settings for a Ricoh Black & White Laser Printer SP330DN.
(I’m on Hrv 56541 Night Build)
It works fine after a few settings.

For this configuration, the printer is connected by ethernet cable in a LAN.
I’m on T470 Lenovo, connected to the LAN by Wifi USB key.

How to set :

  1. Go to preferences, Printers.
    Click to Add a printer


  1. Name your printer. PS compatible type, LPR connection.


  1. Make it default printer (if not, you won’t be able to print)


  1. Click on Print test page


  1. Check your paper setup (A4 for me)


  1. Enter the IP address of your printer in the LAN.
    (I did not change Queue name)


  1. Now the printer shoud have printed the test page. If not, it does not come from Haiku, nor Ricoh.
    Check IP settings, firewall etc…

How to print PDF files with this Ricoh.
I think there is a small bug with “all page settings”, so I show :

  1. Open a PDF with BePDF and go to print.
    (For this example, I took a page from the user guide)

  1. Select Gray scale Mode


  1. Now comes a small bug.
    Don’t let the “All pages” in Print job setup, or it will fail to print telling you that there is no page to print.
    Click to set Print job setup


  1. Here are the correct settings :
  • select Floyd-Steinberg
  • put gamma to 1
  • Ink to max
  • Indicate to print from page 1 to the end of the document (here, only 1 page)

  1. Let’s print !
    Print Job setup has changed. It’s ok to print now.


Page is printed.

Good luck everyone !


Can we add this tutorial to the besly knowledge base?

Off course !
I already sent a email to this morning, proposing to add the printer.


Beautiful Tutorial
Great work, thanks a lot.

For USB Printers?? or LPT ones?

Off course, it also works with USB !

  1. Connect the USB cable to the computer (Printer has to be on)
  2. Restart the computer
  3. Go to Preferences → Printers
  4. Add,
  • PS Compatible also,
  • Select USB Port (don’t worry about the “Language Error Language Error” message



  1. Make it Default Printer

  2. Print a test page.

Works very well