Printer IPP HTTP/1.1 426 Upgrade Required

iam new on HAIKU and at the end of my installation the only thing I do net get solved is connecting by printer via Wifi/Lan:

When choosing the right Epson Model from Gutenprint I try to connect the printer. I looked up the IP within the Printers Dialog, but I get returned the Message “HTTP/1.1 426 Upgrade Required”.

As I understand the connection is correct, but some protocol does not match. I did not find any solution here in this form, sorry.

Do anyone have a hint to solve this?

1 Like


Here, below, some several reasons when you can get such message

How to troubleshoot a 426 status code

Here are some ways to troubleshoot this error:

  • Check for server configuration issues: The 426 status code occurs when the client requests an upgrade to a different protocol version, but the server can’t comply with it. In such a case, you can check the server configuration to ensure that it supports the requested protocol version. You can also check if the server is configured to support HTTP/1.1, which is required for protocol upgrades.

  • Check for client-side issues: The 426 status code can also occur if the client is sending incorrect or unsupported upgrade headers. In such cases, you can check the client-side code to ensure that it’s sending the correct headers and supporting the protocol version that it’s requesting.

  • Check for network issues: The 426 status code can also occur due to network connectivity issues. In such cases, you can check the network settings and ensure that the client and server are connected to the same network. You can also check for firewall or proxy settings that might be blocking the request.

  • Update software versions: If the server or client is outdated, it may not support the latest protocol version requested. In such cases, updating the server or client software to the latest version may resolve the issue.

By following the above troubleshooting steps, you can identify and resolve the issue that’s causing the 426 status code.

Notes from me :

If you are not a web developer - it may not help you.
Also me not the proper person from who you can get step-by-step instructions about it.
I just wanted to give some hint where you can turn to to find a way to get reason for your issue and soime track to follow.
This way it is a hint as well, but may not which one you hoped in.

Since you are trying to access it through IPP, maybe your printer supports ( and it is disabled ) the enabling of more IPP protocols ( 1.0,1.1, 1.2, etc ) . On one of mine I had to enable normal ( http ) access also, because it wouldn´t work with https ( neither from haiku nor windows ) .

That would a configuration you need to change in the printer, through its control panel or acessing it via a browser.

I’m sure everyone could find that page using a search engine. And it looks like AI generated content which is very vague and not helpful. There is really no need to copy that on the forum, it just adds noise and confusion to the discussion.

The most usual reason for this error is that the printer wants to secure the communication using HTTPS instead of HTTP. It seems we don’t support that yet in Haiku (the printing support really needs some upgrades).


Hi PulkoMandy,

I aggree with your Term “noise”. Before I posted my Question I did a search on web and also found this common information (not really helpful).

I did a lot testing on my different settings of printer (activating/dectivating IPV6, allowing HTTP instead HTTPS, reset of software, etc, Thank You @RogFanther). As all other devices (WIN11, Android, IPAD …) work fine on my printers within my local net, this is indeed a problem within HAIKU, I think.

Last Question: when I cancel the connection to printer I get the info “init_transport failed”
I Use for Epson https://(My IPv4):631/ipp/print

Does this mean, there are some https protocol missing within HAIKU?

If I remember correctly, the printer driver uses its own (very old) HTTP implementation. Later on, a more complete implementation of HTTP and HTTPS was done (for the “netservices” library), but the printer code was never updated to make use of it.

It could possibly improve the situation here, and would at least provide with an easier way to debug things, since the new code can trace everything that happens with the requests.

I terribly sorry I tried to help to an expert.
Also feel sorry I’m on so unuseful level of knowledge I’m causing such noise here.

Sometimes who aksk for help here has not enough basic knowledge, so this way I suggested what I posted.

Thanks to put me there where you felt I should be - you just did to me I did in case you :
I had not measured well the situation.

I will make a difference in the future if someone asks for hint instead of help or advice.
I’m going to let the experts give some proper answer.

Have a nice day.