Playing with fusesmb

Just a couple of notes on fusesmb.

I’ve found that out of the box it didn’t find any of my shares. I created a file: ~/config/settings/fusesmb/fusesmb.cache where the contents of each line are:


Where <workgroup> is the workgroup name, <server> the server name and <share> the name of the shared folder on the server. e.g. I have a line that reads /WORKGROUP/fermat/video

If you want to do this from virtual box, use a NAT network card and set up port forwarding for ports 139 and 445.

Finally: jua says this is a nasty hack and I should raise an issue for it so it can get fixed. But I have to go now…

EDIT: removed download and .config file stuff as per humdinger/Julian’s comment.

EDIT2: issue raised:

For what it’s worth, I’m running Haiku natively and have a Synology Diskstation NAS. After installing FuseSMB from HaikuDepot and activating “SMB client” in the Networking preferences, it all just works. Auto-detects my “SMB network” and I can browse my shares after entering once my login and password.

Great work, Julian!
I just wish it was faster. :slight_smile:

Posting this on behalf of Julian, who has issues logging into the forums currently:

“All of this shouldn’t be necessary, and some of it is wrong (login data isn’t read from fusesmb.conf in the Haiku port). It should simply work without any hand-editing, just like humdinger described. If there are problems with scanning for shares, please file a bug report on the project site. Also, the package is in Haiku Depot, no need to build it manually.”

yes… I use a Synology Diskstation too, and it just works! (slow but it works!).
Didn’t know about this program… very nice! Good news!

Great to have, thanks Julian…

I use a WD NAS and also works out of the box, and while its a bit slow, but major leap forward. Big thanks!