Pkgman update not updating hrev number


#1

I have tried twice with pkgman update to update to latest nightly x86_64bit. I think it is actually updating to latest but not updating the hrev number in about haiku. The reason I think this is the second time today when I used pkgman update, it said it was updating to the latest (cannot remember number) from the number before but about haiku was still showing the number before even that. That is when I updated by dd from a usb stick. It seems like the only way to update the about haiku window is to dd from usb stick. To make it update at all with pkgmen update I had to re write the repository file with: pkgman add http://packages.haiku-os.org/haiku/master/$(getarch)/current
and
pkgman add http://packages.haiku-os.org/haikuports/master/repo/$(getarch)/current


#2

The repo package URL has changed. To fix it run:
pkgman add https://eu.hpkg.haiku-os.org/haikuports/master/repository/x86_64/current pkgman full


#3

Thanks, that worked.


#4

I noticed this as well when updating the system via the Software Updater utility over the past few weeks. I’m running the 32bit hybrid.


#5

Also you need to do a reboot after updating core Haiku packages to load the new hrev.


#6

I always reboot after an update since normally it’s fast. However, it hasn’t made a difference in the hrev changing.


#7

Can you check what repo are configured?

In Terminal type:
pkgman list-repo


#8

I’ll do that this evening (when I get home from work) and I’ll reply with the results.


#9

Here are the results…

~> pkgman list-repo
        Haiku
                base-url:  https://packages.haiku-os.org/haiku/master/x86_gcc2/current
                priority:  1
        HaikuPorts
                base-url:  https://packages.haiku-os.org/haikuports/master/repo/x86_gcc2/current
                priority:  1

#10

Your repo appears to be correctly configurated.

You still are pointing to the old manual Haikuports repo, but this not must be the cause of your issues upgrading the O.S.

If you try:
pkgman full-sync

You can update your system? What is the output?


#11

This is exactly the reason why it doesn’t update Haiku. Solution is to run the same commands from the second comment in this thread.


#12

Okay… Well I had a BASH script that did (I think) basically that as well trigger the update and reboot. I used it until the Software Updater became a thing. I guess my questions is… why isn’t SoftwareUpdater not doing this?


#13

You mean automatically reboot? Some people wouldn’t like that, I suppose. I’d rather reboot myself when it’s convenient. One could argue for a “Reboot now” button, I guess. -> enhancement ticket.


#14

Humdinger,

No… the BASH script I created that included updating the repo URLs, running the system update and then rebooting was from some instructions that were shared with me sometime back. I just wrapped those instructions into a BASH script and would run it from time to time if I knew there was a Haiku update available worth installing.

I guess my question concerning the Software Updater had more to do with updating the repo URLs if that is what’s needed to actually get the latest Haiku update. I guess a user prompt offering to reboot would be hot.


#15

Sorry! I didn’t know that the new automated Haikuports repo are necessary to also update to recent Haiku builds. Thanks to point that! :beers:


#16

The instructions from the 2nd comment seems to be downloading the whole shebang of Haiku… is that expected? It was pulling everything down it looks like. I killed it in the middle of the process, so I was wondering if there was a way to purge anything that was cached?


#17

Never mind, it looks like I finally got my hrev to bump :slight_smile:


#18

Yes, that is normal, because the first time that you do a “full-sync” against the new repo, the system replace all your previous versions with the ones available at the new repo. This take a long time, and depends on how many packages do you have installed.

But from there, the sucesive upgrades are shorter, like the previous one against the “old” Haikuport repo.


#19

I’m having the same problem again. The repository address worked for a while now I cannot update to latest hrev in x86_64. It seems the only way is dd from USB drive or is there another change of address somewhere? I looked but could not find it.


#20
  • pkgman full-sync