Personalized Moe crashes

Before filing a bug, I’d like to be sure if I’m doing all right:
I took a gif on the net, splitted in its single fotograms with gifsicle (gifsicle -e filename), (tried also to convert single fotograms to pngs) then used moe to generate the animation (Moe --add-anime=animename --wait=1 files[…])
Then it places the attribute on the first file, but when I launch moe with this file, the first frame compares and then Moe crashes.

no log changes involved.

Is it my fault or a bug?

Crashes are always a bug :slight_smile:

Please save a debugreport from the crash so it can be investigated.

1 Like

Placed the issue here
should I attach the zipOmatic’ed animation?

Yes, that will help reproducing the issue

Need help for a basic task, AFAIK zipOmatic should create a compressed file that includes the source binary file + attributes, right?
But if I zip the file mentioned before it compresses only the binary data and not the attributes. In this specific case the attribute is quite big 410kb compared to the single image 11.17kb… the compressed file is 11.33kb. It obviously does not contain the 410kb of attributes
Where am I wrong?

Are the atributes you are using non-standard in any way ? Maybe it is making them to be skipped by ZoM and also related to the crash

Don’t know how can’t it be a non-standard attribute, this is the screenshot of file informations
third row shows the Moe’s generated attribute

Sounds like a regression in zip-o-matic to me. If there is no bugreport about it already, it means you can open a second bugreport…

It appears to be related to the size of the added attribute.

Regular zipping up from Terminal reveals:

zip warning: not enough space in extra field for attributes

In a test, a 4 KiB attribute worked, a 100 KiB didn’t.
Icon-O-Matic Zip-O-Matic pretends to work, but only zips up the file itself, stripping all attributes.

So, does it works as intended? Or should I consider @PulkoMandy suggestion?

Consider his suggestion. Even if that is by design, a better error message should be presented, so to make clear that the attributes were not included and why.

How woud this be by design? What would the reasoning be for such an arbitrary limitation? Obviously it is a problem and it should be fixed

1 Like

You have mistyped it.

Thanks, corrected. My brain was on Aut-O-Matic… :slight_smile: