Overheating issues


#1

Hello. This is (at least for me) a little strange. I have an old laptop with some temperature issues. Under linux, I don’t get any issue. But under Haiku, if I have heavy cpu usage, the laptop clearly overheat and shutdown automatically.

I set the option at the Process Controller to “low power usage”, but apparently don’t change anything. Also, I had the option “Fans always on” at the BIOS.

There is some reason for this behaviour? Is because somer “power management” lacking in Haiku?

Thanks in advance!


#2

attached the output of your syslog, we can’t help much without knowing some info about the laptop.

The output of lsdev and listusb would help also.


#3

Hello cb88. Yes, you are right. I recollected all the info in this ticket:
https://dev.haiku-os.org/ticket/14954

Thanks!


#4

Theoretically all hardware should have hardware safeguards to prevent overheating. Older systems might simply “shut down” and a lot of newer systems have forced CPU throttling.

I suspect we are doing something to aggravate an existing problem. Since we don’t have GPU acceleration (and do everything CPU-bound), we’re harder on the CPU than a lot of other operating systems.

Just to eliminate one possible cause, have you cleaned your CPU fan lately with a compressed air can?


#5

Hello kallisti5. Thank you for your suggestion. I will try it. I’m pretty sure that the cooling system is not working as it should.

My question was more related about what could causes the (probably) 10 or 15 celsius extra in Haiku. Your suspect about lack of GPU acceleration makes senses. Also, in the listdev output I found something related to Thermal System:

|2|device Signal processing controller [11|80|0]|
|---|---|
|3|  vendor 8086: Intel Corporation|
|4|  device 2932: 82801I (ICH9 Family) Thermal Subsystem|

This device is only to monitoring the CPU temperature, or also had some functionality related to reduce CPU speed or something like that?


#6

Normally the ACPI system handles this on its own. However, I wonder if the “fan always on” mode in the BIOS just disables that, and lets the fan always run, but also always at the minimal speed, instead of spinning faster when there is too much heat? Did you try without that option?


#7

No, usually this option is intended for liquid-cooled systems, which need the power supplied to the “fan plug” to always be at maximum, as it will be running the liquid-cooled pump. So that should not be the case.


#8

It’s a laptop…not sure it has anything to do with liquid cooling unless they just forgot it in there. I had one laptop that had such options but it was mainly as it had a socketed CPU that could run at higher TDPs… and you’d prefer it to run untill thermal thottling against the cooling solution instead of self limiting at a lower TDP to keep fan noise low.


#9

Hello and thanks for all responses! Now, I’m trying disabling the “fan always on” option from the BIOS

I will update this thread (and the ticket) with the results. :slight_smile:


#10

Probably the ideal thing to do is take the back off the laptop and repaste the CPU with a pea sized drop of thermal paste… some Artic MX-4 is cheap and will last the rest of the life of the laptop it’s also non conductive so, low risk to apply.

Old paste from the factory often goes bad after some years… and causes it to hold in the heat more than it should. As far as why it doesn’t do this on Linux… maybe power manangement is just good enough there that it isn’t noticeable, it would be noticeable if you ran a long running task though it would stay throttled.


#11

Hello. There is the update:

I tried with the “Fan always on” BIOS option disabled, but the result are the same. Also, in Linux the temperature ranges doesn’t changed after disabling that BIOS option.


#12

Is there any sensor monitor to see the temperature? I feel my ‘Lenovo’ z470 is very hot but don’t know how to see that.