"Operation would block"


#1

Hello,

I recently installed Haiku OS on an Intel Mac Mini from 2008. It worked fine, right up until I brought it to school. I connected it to the school network via Ethernet and had to register its MAC address to get it to connect. It can ping servers just fine, but for some reason, anything else (like trying to load a webpage) yields an “Operation would block” error. Does anyone know what’s the matter here?

Thanks


#2

Is your school doing anything funny like redirecting all traffic to ssl or do they have a login page that you get redirected to?

One thing you might try switch the user agent on your browser in windows to match Haiku and see if the same thing happens, if not try loggin in with the Haiku user agent set in your windows browser eg firefox (there are addons that let you switch user agent). Then reboot into haiku and see if the internet works from webpositive…

My webpositive user agent is the folliwng for intance: Mozilla/5.0 (Macintosh; Intel Haiku R1 x86) AppleWebKit/606.1.4 (KHTML, like Gecko) WebPositive/1.2 Version/11.1 Safari/606.1.4


#3

It’s not just the browser - telnet and SSH do it too! I tested the user agent and it worked on my Windows laptop. As for the network, I am unaware of any SSL or login-page crap.


#4

It may not matter if you haven’t logged in with a browser that makes the wifi AP happy… it could still be trying to redirect you or there could be some other problem I haven’t thought of.

You could try the otter brower etc…


#5

He connected with Ethernet, no wifi AP.


#6

Yeah didn’t see that but it’s still a router that is apparently requiring his MAC to be registered and all that entails…


#7

Just figured I’d give a little update: the issue is resolved. It was an issue with the school network - Cisco ISE didn’t recognize my OS (Haiku) and thought I might be a hacker, so the machine was being blocked from accessing the network.


#8

Nice! But it is solved now?


#9

Yep, network is (net)working now. Bonus: does WebPositive support YouTube video? Qupzilla?


#10

You can test then.


#11

Yes it was broken for me last week but youtube works again (crashily).