Operation Would Block

I have a weird issue where Haiku will not connect via the internet, but will for anything on the lan side. I have a pi-hole setup for DNS, which it does contact to get records. I can ping outside addresses/domains but using traceroute, wget, or webpositive will all end in failure.

I have some internal sites and ssh terminals which Haiku will connect to, just nothing external. Seems anything that needs to pass to the gateway will not route. I have tried both DHCP (which works) and static assignment, all fields are entered, but still nothing. I do have ipv6 disabled, and when a lookup is called, it will first try ipv6 addresses, fail and quickly use ipv4, but then nothing happens. Is there something I’m missing, I’m at a complete loss why every other machine on the network works, and this will for all internal sites, but won’t connect to anything via WAN side.

Also note, nothing is blocked on the router either. The connection is hard wired, jumps through two switches and then the router, via rj45 to fiber (fios) connection. The logs on the router don’t show any routing requests from the notebook, so it looks like it’s not routing to any external ip addresses.

Notebook is an old Dell Latitude C840, P4 2Ghz with 512Mb ram.

Best and happy holidays.

Sounds like haiku may not use the dns server you expect, can you verify that it indeed used the pihole server for its dns?

Yes, it is. I even tried changing it from the pi-hole to cloudflares and googles, still nothing. And when I enabled logging, I could see the notebook making requests for domain names.

When I do traceroutes it will show the correct ip address as well. Issue is so weird, I feel like the answer should be looking at me in the face. :confused:

edit* to clarify, it seems like the DNS lookup is working, just the routing goes nowhere.

Anything suspicious in the host file?

Host file looks fine, the resolv.conf file looks right, the network file also shows auto for dhcp and correctly fr static assignment.
It will also not update from the package store, HaikuDepot?

Sounds like https://dev.haiku-os.org/ticket/17211

@korli That does indeed sound like it. I will turn off the firewall on the router and see if the connection goes through, thanks for the link.

I still couldn’t get it to work correctly even with the firewall disabled on the router, however, after reading over the ticket, someone suggested to install a nightly since the tcp network stack was recently updated. I installed the latest nightly for 32bit, hrev55742, and everything works great.


Then it might look like https://dev.haiku-os.org/ticket/13681#comment:11

That sounds more like it, I have no way of getting any logs for the dropped packets from the router though to be sure.

The good news is the updated nightly build works great. :slight_smile:

1 Like