Old beos programs and games not run anymore

Born out of a other discussion (Some aspects of packagefs) i start this one to get a overview that programs and games does not run anymore.

  1. Call to Power (Last run on beos)
  2. Corum III (last run on beos)
  3. Inside Constructor html editor (Last run on beos)
    https://dev.haiku-os.org/ticket/12551 (not really fixed)
  4. Inside Designer html Editor (Last run on beos)
  5. Doom
  6. Refraction
1 Like

Doom has several replacement engines available. “Chocolate Doom” is the one staying most close to the original implementation and is available in HaikuDepot.

Refraction: https://dev.haiku-os.org/ticket/12554 I asked a question 4 years ago and didn’t get a reply. Still waiting for your results :slight_smile:

Insite Designer: tickets are closed, if it still doesn’t work properly please open new ones (as waddlesplash asked to do 10 month ago there).

Corum III: the bug was in ffmpeg and we have updated to a much newer version. Is the ticket still valid?


Ok i see i need to check the old reports ;).

Moho 2.5 runs well with BeOs. With Haiku it gets the wrong paths…
I think it is a ffmpeg problem there too. The program works fine in 32bit but you cannot save the animatons! Maybe there is a way to ajust the paths to the encoder!?

Exposer: Missing in Action too!

Freedroid is missing too (not the freedroid RPG!)

I really liked Eric’s Ultimate Solitare. It wouldn’t run last i tried, and it seemed to use private api calls.