Old beos for download

I used BeOS several years ago before it died and have since lost my BeOS install CD. I have tried installing haiku and beos max, but have only had trouble with it and don’t have the time I used to, to fiddle with it until it works. Does anyone know where I can download the old BeOS? I can’t remember what version it was, I think it was R3 or R4…

also, could someone create an iso that can be burned from windows? If the iso’s provided can be burned from windows, maybe my download is corrupted or something…

The latest old BeOS should be R5.
The best choice would probably be to download one of the BeOS Max editions, especially Beos Max V4, which you could get from www.beosmax.org (currently it does not respond).

Download the beos-image, the corresponding boot-image(you have to look either for the intel or the amd-image - choose the right one for your computer) and the corresponding .cue-file, which instructs Nero on how-to burn the two images one after another onto the CD.

There are instructions available all over the net on how to burn BeOS CDs with Nero, I don’t have the time to explain it in all detail right now

Generally speaking you have to open the .cue file with Nero, everything else should work fine.



I downloaded R5 from beosmax.org and used Roxio to burn… It recognized the cue file and after it burned, I saw two files on the cd. Does Roxio just not work for beos cds?

Not sure for Roxio. But it’ll work with Nero.

You have to choose “burn image” and give it the cue file.

After burning the CD. The only file(s) you’ll see are.

floppy.img ( or boot.img? ) - size 1.44MB
boot.catalog - size 2KB

You shouldn’t see any other files than those above.

Edit: The BeOS image is hidden on the disc ( because BFS format? ) and can only be seen with BeOS OS not in Windows.

oh… well, I’ll try it again. Roxio showed an error during the burn process, which could have been because it didn’t recognize the beos image. When I opened the cd in explorer, it showed only two files and only 1 1/2 mb taken up. Which could have been because of the beos image.
thanks for your help

Alright, I burned the beos max onto a cd with nero and all I get when I try to boot from the CD is a boot failure.
Am I supposed to make a floppy boot disk ? I’ve tried the floppy maker, but when I try to boot from that, it tells me there are too many disk errors…

I haven’t downloaded BeOS Max4 so I’m not exactly sure the files on there but I believe you should have following:

a) 2 cue files ( AMD or Intel )
b) 2 boot image files ( AMD or Intel ) - usually named xxxxxx.img ( ie: boot.img or cdboot.img or floppy.img )
c) 1 disc image ( BeOS install )

The cue file, is just a text file, you can open it up in a text editor & look at it ( or change it ). Open both cue files & have a look at them. They should be the same except for the different boot image used.

When you burn the cue file, it tells your burning program to burn the ( INTEL or AMD )“boot image” file as track 1 and “BeOS disc image” as track 2.

You shouldn’t need any floppy loader.

In Nero. You select “Burn Image” from the Menus, then give it the cue file.

Also, when burning, try a slower speed - you might be going to fast for your media (ie: if the disc says 40x, burn at 32 or 24x, if CDR 32x then do 24x or 16x, etc ). And on the burn screen turn on disc validate ( sorry can’t recall exact name, it checks the disc afterwards to make sure it matches with the data on the hard drive ). Your CDR may be bad? Or you’re getting a bad burn?

And you should install & use Winrar if you don’t already. Use Winrar to test BeOS MAX zip’s integrity to make sure it isn’t corrupted. I strongly suggest doing this first to make sure the zip is OK.

thanks, I’ll give it a try.

and fyi here are the files in BeOS Max4

Directory of D:_DL\BeOS\BeOS5PEMaxEditionV4b1\files
FLOPPY MAKER call me under BeOS
FLOPPY MAKER call me under DOS or Windows.BAT
FLOPPY MAKER call me under DOS or Windows2.BAT
IDE REPL FLOPPY MAKER call me under DOS or Windows.BAT
22 File(s) 681,689,306 bytes

and here is what gets burned on my cd.

Volume in drive E is bootimg
Volume Serial Number is 73D5-346D

Directory of E:\

10/20/2005 11:28 AM 2,048 boot.catalog
10/20/2005 11:27 AM 1,474,560 boot.img
2 File(s) 1,476,608 bytes
0 Dir(s) 0 bytes free

ok, thanks for the file list, that helps.

Wow, talk about making it complex. That is too many files to have on the disc - it’ll get confusing.

The 2 files burned to your disc look right. That is what you should see.

Also make sure that track 2 is being burnt. BeOS image file.

Now, something I noticed, which could be affecting you.
BeOS R5 has a ram limitation of 1152MB. This means System RAM + Video RAM should not exceed 1152MB.

There are boot images with RAM limiter to lower your System RAM to 256MB, 512MB, 768MB & 1024MB.

Looking at the Intel cue files ( same applies to AMD cues files ). I see:

MaxV4b1_Intel.cue - NO RAM limiter, so problem if System RAM + Video RAM > 1152MB - won’t boot.

MaxV4b1_Intel_1024.cue - RAM limit at 1024MB ( won’t see more than 1GB System Memory even if you have over 1GB installed ). Problem still if Video Card RAM is over 128MB.

I’m surprised RAM limiter of 512MB was not included.

Edit: Fixed RAM limits.
More information is here:

512MB RAM Limiter

You’ll also need to replace zbeos file on hard drive because it has the RAM limiter code. Otherwise you won’t be able to boot off the hard drive.

I’m running a system with 512mb ram, 40gb hdd, 2ghz cpu. I shouldn’t need the limiter, although I’ve tried burning a couple cds with it.
When I boot the system, it doesn’t realize that the cd is a bootable cd. It just proceeds to boot into windows xp. I’ve tried using nero & roxio.
I’ve tried making boot floppies too, but they don’t work either. I’ve got some other computers that I’ll try sometime, does beos not like asus mobos?

I just tried using the amd cue to burn a cd and boot with it. still nothing.
When using either cd, the pc starts and reads the cd, thinks about it, and then goes on to xp.

Strange, not sure what is causing it to skip booting off the CD.

With 512MB RAM you very likely don’t need a RAM limiter. Try burning both cue files for your cpu ( AMD? ). Won’t matter if you use the RAM limiter or not for you.

Depends on your motherboard chipset. I’ve had no problem running BeOS Dano on VIA & Nvidia chipsets ( & Intel work good too ). Not sure about SiS & ATI motherboards though.

And can’t say for BeOS R5.

I took a few of the beos cds home this weekend and tried them on my own computer and beos started to boot, so I’m pretty sure the cds I made burned right. However, when I booted with the cd, it showed the beos boot screen for a few seconds and then restarted. It never finished booting.
My guess is the computer I was trying to load it onto at work just isn’t supported. Not sure about the one at home, I might have just had the wrong cd available. I burned a whole bunch of intel cds, but my computer might be amd…
I’ll try again later.
Thanks for your help.

Is it an AMD machine? - IIRC, that’s the behavior that is demonstrated when you boot BeOS on an AMD machine without the AMD patch applied.

Not for BeOS Max but for ZETA 1.1 you can find a tutorial how to burn a BeOS CD with a CUE file. It is the same process for all BeOS Versions.


Greetings Lelldorin

I’ve had luck suing cdrecord for windows and this command string:
cdrecord dev=0,0,0 -eject -v -data -dao -pad -padsize63s drive
ropts=burnfree gracetime=0 intel_r5.0.3_boot_cd.img BeOS5PEMaxEditionV4b1.iso

this floppy image and iso image are different based on your needs. worked perfectly for me. if you have more than one drive, “dev=0,0,0” will be different for you.

Good luck