Old BeOS code developer evaluates Haiku beta2

Been a few years since I tried to run Haiku. For the past 11 years I’ve been living aboard a yacht, which isn’t really conducive to doing such things. Last night I noticed that a beta release had been made this year so I decided to try it. Here are my findings.

Hardware: Dell T7610 workstation.

Configuration: Dual Xeon E5-2630 v2 @ 2.6GHz, 64GB RAM, DVD, BluRay, Wi-fi, Logitech wireless keyboard, PS2 mouse.

Storage: 500GB primary SSD (drive C), 110GB primary SSD (old Haiku drive), 110GB primary SSD (experimental Haiku-compatible OS), 500GB external SSD USB backup drive (drive D), Fujitsu 500GB general storage drive (drive G) used mainly for genetics research, storing genome files and so on.

Comments: Neither of the 110GB drives will completely boot on this hardware.

Software: Windows 7 SP1 64-bit

Procedure: Burned the ISO onto an SD card using a USB card reader and Win32 Disk Imager. Rebooted, set BIOS to boot off USB and away we went.

Stuff that worked:

  1. The CPU fires up on all 24 cylinders, and all memory is recognised. I’m impressed that it actually booted at all on such modern hardware. Kudos, this is progress.
  2. I can run 10 rotating teapots at 125 fps, limited mainly by video speed. Pretty good.

Stuff that didn’t work: I’ll try to keep a neutral tone in order not to offend anyone. This is NOT a comprehensive list, just what I noticed within 5 minutes of booting.

  1. Can’t see HaikuOS SSDs attached to the system. At all. I can see them with BFSViewer from Windows, so they’re not dead.
  2. Drive C is represented by a drive marked “unnamed” which seems to be the 100MB system partition; the actual drive C isn’t visible, nor is drive G. Drive D (external) is mountable and readable.
  3. WebPositive is almost useless, it can’t even go to links in the docs when they’re clicked.
  4. Egasky Venu 2414 wi-fi extender doesn’t work. Ralink USB wi-fi dongle doesn’t work (uses same RT3070 chip). Since I’ve had both of these working years ago on Haiku, we seem to have gone backwards.
  5. No English date format available, only US-style MM/DD/YYYY (trivial but annoying)
  6. “Could not find the mixer.”
  7. No video or audio input or output.
  8. Haiku3D won’t close.
  9. Random lockups on several other programs tested briefly.

Rating: A for effort, F for usability.

1 Like

The date format is configurable in preferences/locale. There is an appropriate default for each language, and if you’re american but want to use a date format that makes sense, you can override it.

The English language default is MM/DD/YYYY and I could see no way to change that.

Haiku R1/beta2 doesn’t boot on any of my computers, but the Nightly’s (for 2 or 3 months - I haven’t noted it)!
Optimal:

  • Mini-PC Zotac ZBOX IQ01 = currently Haiku PC
    Boat (‘then’):
  • Mini PC Zotac ZBOX ER51060
  • DELL Notebook XPS-15 L502x
    Not yet tested:
  • ODYS Wintab 9 Plus 3G tablet

When Haiku R1/beta3 is out, I’ll test all computers with it (for life and health), as well as various hardware (internal, external) and software (including Ancestris, digiKam, video editing, …)

I stopped downloading nightlies after several months where none of them would boot, even on known working hardware. Looking forward to beta3.

Ugh! Well, that is not the default for the English language, so that should be changed. Outside of the US, we all use the regular DD/MM/YYYY format.

The other think I notices a while back was that there seems to be no way to specify 24 hour time format. In the UK we don’t use AM/PM anymore, we use 24 hour format normally. It’s only really the older generation (given I’m over 40, you can see who I mean) that still cling to AM/PM. We do still use it in writing, so I will sometimes use it if I write something like “I’ll see you at 7”, as that is ambiguous, but every clock I own is in 24 hour mode.

You can pick a more specific language than just “english” in uhe locale preferences in the tab where you adjust date and time format. The default for “english” is indeed american english, because, well, it has to default to something, and that choice is as bad as any other one.

Just be a little more specific with some other country and it will be fine.

Haiku comes prepared for the Brexit :wink: (sorry couldn’t resist) :smiley:

2 Likes

Probably fixed in nightlies.

If lockups are permanent, then please tell what programs and actions exactly was used. It it just freeze for some time and then continue operation, then it is likely #15585.

+1. US date style is terrible. Many users use English language but different date format.

Extremely easy to rectify: Preferences -> Locale

screenshot

1 Like

Does that also then show the correct 24hour format fpr the time in Tracker? It used to be a preference in OpenTracker at one point. Maybe that is why I missed it? I am pretty sure I set my local to UK. My Haiku laptop s under a massive bile of boxes in storage at the moment as we are in a prolonged state of moving house.

First, you’d want to update your installation:

  1. pkgman full-sync

  2. shutdown -r

This will get you the recent OS updates so you can review from that point.

i use otter browser on a daily basis for a wide range of things, including movie streaming, with no issues

Yes, there are two tabs in the interface for Locale. The formatting tab changes in real time so you can judge the results.

Hey there :smiley: Welcome to Haiku! That’s totally amazing that you worked on code in BeOS, for real! Saw the title :slight_smile: I can bet it probably was a lot harder to build stuff back then! :mantelpiece_clock: I’m both a geek of the retro series (did a retro review saga on the old school stuff (R3 to Haiku alpha1) since I couldn’t find anything that really explored them) and today’s stuff like Haiku :smiley:

Anyways tbh I’m not on the Haiku dev team, just a hardware tester, but I thought I’d reply to these anyway; afaik even though it’s improved, work is ongoing on SSDs, not all filesystems are supported (so if this happens to be APFS, ReFS, etc it won’t be visible afaik), or they could be filesystems Haiku can see but they’re prob not visible to Haiku because of ongoing work on stuff like SSD support. imho, :earth_americas: Web+ has improved a lot since the Beta – try it out in a Nightly (download.haiku-os.org), also try out Otter from the Depot. For a small browser it’s amazing what it can do! But yeah, it’s got a long way to go; try the Locale preflet to fix the date format.

Try opensound to get the sound to work. As the guy trying to work on “Haiku on Mac” I totally get the no sound problem as most Macs I test out with Haiku are silent :cry: For the Haiku3D thing and freezes :ice_cube: try out a Nightly and see if things work better! :slight_smile: From entries I see in the hardware list, definitely try out a ThinkPad as those seem to have good support. And anyways, good luck and hope this helps!

1 Like