"o Sys Loader!" error appears on Boot

Hello! I was attempting an install of the latest beta version of Haiku on an HP Probook 850’s harddrive. The setup appeared to go successfully but when I got to booting up the system I got the following error: “o Sys Loader! (sic)” on a blank black screen. Any idea what has gone wrong? Thank you!

1 Like


The stage 1 bootloader is not finding the other parts of the system.

So the install did not work as expected.

I’m not sure which version of the Probook 850 it is, if it is a modern one you may try installing the EFI bootloader (this requires some manual steps, it’s not integrated into Installer yet).It may work better than the legacy BIOS one.

1 Like

A note: 850 is a typo due to my bad eyesight. It’s 650. Specifically “HP Probook 650 G1”.

Any guides to installing the EFI bootloader? Thanks.

1 Like

Could this page be linked in the Installing Haiku that appears at the front page of haiku-os.org ? Installation Guide | Haiku Project .
I searched for it first there, and couldn´t ( easily ) find a link to send amor.kya.

Just tried this twice. This time I got my classic:

Boot device not found.
Please install an operating system on your harddisk.
Harddisk - (3F0)
F2 System Diagnostics
For more information please visit: www.hp.com\go\techcenter\startup

This happened both times I tried the instructions here. Haiku is going to be the only OS on my system so I used the basic method. Perhaps it’s an HP specific problem?

Edit - after reviewing other articles in here, yes I did unmount the EFIBOOT partition before rebooting.

1 Like


nvme disk - only CSM/Legacy bios
usb disk /usb box ext./ - uefi + CSM/Legacy bios