Noob question about browsing network

Hi all, I’m on day 2 of running RC4 on my Linux-hosted QEMU. I’m still getting up to speed with the interface and apps, and would like to know if there’s a straightforward way to access my network shares, especially Samba shares? I’ve installed smbfuse but am perplexed as to the next step. Can someone please point me in the right direction?

First, click on the Deskbar menu and go to Preferences.
Click on Network
Under Services, make sure SMB client is Enabled

After that, you should see an icon named “SMB Network” on your desktop
You can double click that and see if anything shows up, assuming your workgroup is named “WORKGROUP”
If you don’t have any SMB1 servers, you probably won’t see anything.

If you don’t see anything, do this:
You can edit the fusesmb.cache file in /boot/home/config/settings/fusesmb and add locations that you know exist, in the form of:
/[WORKGROUP name]/[server name/ip]/[share name]
(an example: /WORKGROUP/NAServer/Pictures)

Save it, then go back to the SMB Network icon and you should see whatever locations you just saved.

fuseSMB will refresh that file after however many minutes you selected in the Network preferences app (max is 120 minutes), so it will get overwritten and you’ll have to do it again.


Thanks for that! The problem here is that my 2 NAS boxes no longer support SMB1, which explains the “missing” shares. I’ll have a look at using NFS instead.

1 Like

Higher than SMB1 won’t broadcast, if I remember right, but it might still be possible to view them if you edit that cache file. I’d be curious to know if you can get NFS going, though.

1 Like

I’m up for the NFS challenge … I’ll be back :grin:


I’m back, and somehow it’s working with NFS.

I can create, edit and delete folders and files. Currently, everything is showing with an “executable” permission so I need to fiddle around with that.


mount_nfs 192.168.XXX.XXX:/data/temparea /boot/home/Desktop/NFS 0 0

In /var/log/syslog:

KERN: nfs: mount(24, , 00000000)
KERN: nfs: nfs_params: nfs:192.168.XXX.XXX:/data/temparea,uid=0,gid=0,hostname=shredder
KERN: nfs:ip!
KERN: IP:192.168.XXX.XXX
KERN: nfs:hn!
KERN: nfs:uid!
KERN: nfs:gid!
KERN: nfs: ip:c0a801a5 server:‘192.168.XXX.XXX’ export:‘/data/temparea’ hostname:‘shredder’ uid=0 gid=0
KERN: nfs: mountd at a501a8c0:45644
KERN: nfs: nfsd at a501a8c0:2049

There’s nothing special about the share on the ReadyNAS RN102:

1 Like

I’m glad that works for you. The only thing I ever get, and have ever gotten, from mount is “Bad port ID”. I still haven’t been able to figure out why.

So, I tried again and have graduated to “no route to host”, which is odd because I’m using the IP address and it pings just fine. But I also can’t ssh to my NAS, because Haiku says the connection is refused. Windows works, though.

So I don’t know what’s up with that, either.

Are you using a firewall on your NAS or client box ? Sounds like a port/port range is being blocked. Re your SSH issue though, have you tried ssh -vv user@serverIP ? I usually find this helps when setting up a new box.

You may try out on a nightly - there were many refactoring/enhancement and fixing bugs related to Haiku network services.

I’ll hack on it a bit more. Evidently my NAS needed a bit more configuration. So I’ll work on that.

I have two Haiku systems: one with the latest beta, and one with a nightly that I update every few days.

ssh -vv gives me this on Haiku and macOS:

~> ssh -vv austin@seaside
OpenSSH_9.6p1, OpenSSL 1.1.1w 11 Sep 2023
debug1: Reading configuration data /packages/openssh-9.6p1-1/.settings/ssh/ssh_config
debug1: Authenticator provider $SSH_SK_PROVIDER did not resolve; disabling
debug2: resolving “seaside” port 22
debug1: Connecting to seaside [] port 22.
debug1: connect to address port 22: Connection refused
ssh: connect to host seaside port 22: Connection refused

On Windows, well, there’s a whole bunch of stuff printed. But it works.
There are no firewalls between macOS or Haiku and the NAS.

My ReadyNas has hardly any configuration options for NFS but I’ll try my Synology DS120J tomorrow which has few more options: I can at least set the version number to 3, 4 or 4.1.

It’s unlikely to work with those. The mount_nfs command only handles NFSv2. There is a native NFSv4 driver which uses a different mount command but it’s prone to causing kernel panics. There are at least half a dozen open tickets on the bug tracker for it.

And I believe that’s what my problem is, after fixing some oddball issues with my network. My main NAS appears to only support NFSv4.

I have an older NAS, but it looks like NFS is not turned on and I can’t turn it on because no web browser supports its archaic SSL/TLS.

Depending on how archaic are we talking… I wonder if BeZilla (requires 32 bits Haiku, of course) might be of service here :smiley:

Possibly. I thought about spinning up a Windows 7 VM. I disabled a setting in Firefox that allows me to get to the login page, but it won’t accept the password so I don’t know how successful anything will be.

If you have a linux machine, you could try, or running an older browser via WINE.

1 Like

I do have a Linux box, but it’d probably be easier just to get a Windows 7 VM running. Maybe I’ll do that today. But, really, I’ll probably just not and wait until the day when either FuseSMB or NFS is updated.