No video signal after switching from B4 to latest nightly

What the title says. After the boot icons light up, there is a white empty screen for 1-2 seconds then no signal. Tried with another monitor, same result. Also happens with a USB stick with same fresh nigthly ISO (hrev56747).

If I boot with VESA driver, everything is fine.

My card is an AMD RX560 and monitor is connected via DP, with a DP-to-HDMI adapter (card’s HDMI port is bad). Did something change in regard to GPU drivers recently? Beta4 defaulted to VESA, but it seems something changed in recent nigthlies and my card doesn’t like it :frowning:

1 Like

Here is the commit log that you can check against your last working hrev:

You could boot into the state that gives you a white screen, reboot into VESA and get the /boot/system/var/log/previous_syslog. Maybe there’s a hint there.

1 Like

Most likely you will have to blacklist radeonhd driver. My 2 boxes both have Navi generation cards and I need to boot with Vesa (radeonhd blacklisted).

Yup, for now blacklisting radeon_hd works. (its a RX460 btw, memory playing tricks on me again…)

According to hrev54403 this card should be at least detected:

-	{0x67ef, 12, 0, RADEON_POLARIS, CHIP_STD, "Radeon RX 460"},
+	// Polaris 11
+	{0x67ef, 12, 1, RADEON_POLARIS11, CHIP_STD, "Radeon RX 460"},

… but it isn’t? (note the 0 to 1 change above)

KERN: radeon_hd: init_hardware
KERN: radeon_hd: init_driver
KERN: radeon_hd: init_driver: GPU(0) Radeon RX 460, revision = 0xcf
KERN: radeon_hd: publish_devices
KERN: radeon_hd: find_device
KERN: loaded driver /boot/system/add-ons/kernel/drivers/dev/graphics/radeon_hd
KERN: Radeon - init_hardware: Version:
KERN: Radeon - Radeon_CardDetect: no supported devices found

lspci output:

~> lspci -n -v -s 01:00.0
01:00.0 0300: 1002:67ef (rev cf) (prog-if 00 [VGA controller])
        Subsystem: 148c:2374
        Flags: bus master, fast devsel, latency 0, IRQ 18
        Memory at c0000000 (64-bit, prefetchable)
        Memory at d0000000 (64-bit, prefetchable)
        I/O ports at e000
        Memory at ff600000 (32-bit, non-prefetchable)
        Expansion ROM at ff640000 [disabled]
        Capabilities: [48] Vendor Specific Information: Len=08 <?>
        Capabilities: [50] Power Management version 3
        Capabilities: [58] Express Legacy Endpoint, MSI 00
        Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+

Reviving this thread 'cause things are worse and I’ve not found a solution yet…

I’ve been unable to boot Haiku at all on my PC since months ago. It was working fine with radeonhd blacklisted, then someday (presumable after an update? idk) I rebooted and was unable to reach the UI ever again. Same thing with the DVI port, I always get “no signal”. Not even fresh install media works, and failsafe video boot option doesn’t help anymore.

As I said, my card has a damaged HDMI port, not physically but it doesn’t work. Card works 100% fine otherwhise, even with heavy 3D loads. I’m not sure but (correct me if I’m wrong) feels like Haiku forces output to this port? which obviously I cannot use… Windows and Linux work fine on DP->HDMI and DVI.

How do / Can I force output to a specific port?

(This is the main thing keeping me from continuing dev/porting work, I don’t have another machine with enough grunt for it)

The failsafe video driver is unable to force anything, and will just let your BIOS or UEFI firmware do things.

Are you sure the problem is the video driver? Did you open a bugreport about this on the bugtracker with syslogs and other useful information?

To access a syslog I need to take out the RX460 and boot with the integrated GPU, right now I can’t do that but eventually I will, and then file a bug report. Or report here, whatever is more appropiate.

… feels like I’m on forced leave :weary:

Unless the system has KDLed (probably it hasn’t) you can just press the shutdown button on the PC itself to gracefully shut down, and then retrieve the “syslog” file using another OS or Haiku install.

And as PulkoMandy said: use the “fail-safe graphics” option in the bootloader, this should bypass any graphics driver problems.

1 Like

Didn’t think I had to write this so many times…

  • I can access the bootloader menu just fine
  • Enabling safe mode does not help
  • Enabling fail-safe video does not help
  • Disabling other things (BIOS calls, ACPI etc) also doesn’t help

Okay, I’ll try the graceful shutdown, thanks :slight_smile: then I suppose I’ll boot into Beta4 to get a syslog… If that doesn’t work, then I will start suspecting the card itself - as I know for a fact Beta4 booted just fine with it.

TL;DR – I had two unrelated problems, not one:

  • 1st was a corrupted installation → fixed by nuking entire Haiku partition
  • 2nd was a working-okay-but-not-quite? graphics card → fixed by replacing it

(What follows is a long read. But I figured it’ll be useful/informative to someone out there.)

In the end I couldn’t diagnose this… No matter what I tried, system was unresponsive past the Haiku logo/icons. I did try a graceful shutdown, analyzed syslogs for anything weird/suspicious, reverted to integrated GPU, nothing helped.

At this point I realized this was not a single problem, but two different ones. So a two-step approach was needed.

For the non-booting Haiku installation I suspected a corrupted system, so I figured better diagnose a fresh one. Booted to Beta4 and did a full backup then nuked everything. First problem “solved”.

Now to the 2nd one: why nightlies boot OK w/integrated GPU but not with my RX460 (no video signal, even with failsafe video enabled). Comparing both syslogs again gave me nothing useful.

At this point I was REALLY fed up, so with nothing to lose I yanked out the RX460 and put a RX590 8Gb I got on a whim from FB Marketplace. (The RX460 went to a friend who says works fine on a Linux PC, go figure.)

With this card, Haiku nightlies boot correctly w/safe video, also I got a nice boost for Windoze games! Second problem “solved”.

After all that, I installed latest nightly without a hitch.

Case is closed, finally! :slight_smile: