No sound with Sigmatel 9205 sound device

I bought a new (i.e. older) laptop to test out the new Haiku Beta 1 release. I updated the system and yet I have no sound in my Dell Inspiron 1720 with a Sigmatel 9205 sound device.

Is there a Haiku hardware compatibility list anymore? It seems that I cannot locate it.

Has anyone used this audio device before?
What about a USB Creative sound stick–is that viable for this release?

Thank you in advance!!

Try blacklisting hda driver and installing opensound package from HaikuDepot.

There was some recent work on usb_audio driver but it’s still not ready at this time and not included in the image. https://git.haiku-os.org/haiku/log/?qt=grep&q=usb_audio

Thanks, I will try that…nice new feature!

I forgot to mention that I’m running the Haiku Beta 1 (64-bit) release.

The listusb is as follows:

~> listusb
0000:0000 /dev/bus/usb/0/hub “HAIKU Inc.” “UHCI RootHub” ver. 0110
3938:1031 /dev/bus/usb/1/0 “MOSART Semi.” “2.4G Wireless Mouse” ver. 8137
413c:8133 /dev/bus/usb/1/1 “Dell Computer Corp.” “Wireless 5720 VZW Mobile Broadband (EVDO Rev-A) Minicard GPS Port” ver. 0000
0000:0000 /dev/bus/usb/1/hub “HAIKU Inc.” “UHCI RootHub” ver. 0110
0000:0000 /dev/bus/usb/2/hub “HAIKU Inc.” “UHCI RootHub” ver. 0110
0000:0000 /dev/bus/usb/3/hub “HAIKU Inc.” “UHCI RootHub” ver. 0110
0000:0000 /dev/bus/usb/4/hub “HAIKU Inc.” “UHCI RootHub” ver. 0110
0000:0000 /dev/bus/usb/5/hub “HAIKU Inc.” “EHCI RootHub” ver. 0200
0000:0000 /dev/bus/usb/6/hub “HAIKU Inc.” “EHCI RootHub” ver. 0200

The listdev is as follows:

~> listdev

device Serial bus controller (SMBus) [c|5|0]
vendor 8086: Intel Corporation
device 283e: 82801H (ICH8 Family) SMBus Controller

device Mass storage controller (SATA controller, AHCI 1.0) [1|6|1]
vendor 8086: Intel Corporation
device 2829: 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode]

device Mass storage controller (IDE interface) [1|1|8a]
vendor 8086: Intel Corporation
device 2850: 82801HM/HEM (ICH8M/ICH8M-E) IDE Controller

device Bridge (ISA bridge) [6|1|0]
vendor 8086: Intel Corporation
device 2815: 82801HM (ICH8M) LPC Interface Controller

device Generic system peripheral [8|80|0]
vendor 1180: Ricoh Co Ltd
device 0852: xD-Picture Card Controller

device Generic system peripheral [8|80|0]
vendor 1180: Ricoh Co Ltd
device 0592: R5C592 Memory Stick Bus Host Adapter

device Generic system peripheral [8|80|0]
vendor 1180: Ricoh Co Ltd
device 0843: R5C843 MMC Host Controller

device Generic system peripheral (SD Host controller) [8|5|1]
vendor 1180: Ricoh Co Ltd
device 0822: R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter

device Serial bus controller (FireWire (IEEE 1394), OHCI) [c|0|10]
vendor 1180: Ricoh Co Ltd
device 0832: R5C832 IEEE 1394 Controller

device Network controller (Ethernet controller) [2|0|0]
vendor 14e4: Broadcom Limited
device 170c: BCM4401-B0 100Base-TX

device Bridge (PCI bridge, Subtractive decode) [6|4|1]
vendor 8086: Intel Corporation
device 2448: 82801 Mobile PCI Bridge

device Serial bus controller (USB controller, EHCI) [c|3|20]
vendor 8086: Intel Corporation
device 2836: 82801H (ICH8 Family) USB2 EHCI Controller #1

device Serial bus controller (USB controller, UHCI) [c|3|0]
vendor 8086: Intel Corporation
device 2832: 82801H (ICH8 Family) USB UHCI Controller #3

device Serial bus controller (USB controller, UHCI) [c|3|0]
vendor 8086: Intel Corporation
device 2831: 82801H (ICH8 Family) USB UHCI Controller #2

device Serial bus controller (USB controller, UHCI) [c|3|0]
vendor 8086: Intel Corporation
device 2830: 82801H (ICH8 Family) USB UHCI Controller #1

device Bridge (PCI bridge, Normal decode) [6|4|0]
vendor 8086: Intel Corporation
device 2845: 82801H (ICH8 Family) PCI Express Port 4

device Network controller [2|80|0]
vendor 8086: Intel Corporation
device 4229: PRO/Wireless 4965 AG or AGN [Kedron] Network Connection

device Bridge (PCI bridge, Normal decode) [6|4|0]
vendor 8086: Intel Corporation
device 2841: 82801H (ICH8 Family) PCI Express Port 2

device Bridge (PCI bridge, Normal decode) [6|4|0]
vendor 8086: Intel Corporation
device 283f: 82801H (ICH8 Family) PCI Express Port 1

device Multimedia controller (Audio device) [4|3|0]
vendor 8086: Intel Corporation
device 284b: 82801H (ICH8 Family) HD Audio Controller

device Serial bus controller (USB controller, EHCI) [c|3|20]
vendor 8086: Intel Corporation
device 283a: 82801H (ICH8 Family) USB2 EHCI Controller #2

device Serial bus controller (USB controller, UHCI) [c|3|0]
vendor 8086: Intel Corporation
device 2835: 82801H (ICH8 Family) USB UHCI Controller #5

device Serial bus controller (USB controller, UHCI) [c|3|0]
vendor 8086: Intel Corporation
device 2834: 82801H (ICH8 Family) USB UHCI Controller #4

device Display controller (VGA compatible controller, VGA controller) [3|0|0]
vendor 10de: NVIDIA Corporation
device 0427: G86M [GeForce 8400M GS]

device Bridge (PCI bridge, Normal decode) [6|4|0]
vendor 8086: Intel Corporation
device 2a01: Mobile PM965/GM965/GL960 PCI Express Root Port

device Bridge (Host bridge) [6|0|0]
vendor 8086: Intel Corporation
device 2a00: Mobile PM965/GM965/GL960 Memory Controller Hub
~>

Hopefully this will help the devs in seeing what can be done.

Blacklisting is not working for me, it is still being loaded insted of the OpenSound driver:

Device name: 82801H (ICH8 Family) HD Audio Controller

I created the ‘packages’ text file as follows:

Package haiku {
EntryBlacklist {
/boot/system/add-ons/media/hmulti_audio.media_addon
}
}

So these drivers must be distributed in many other places. Too bad I cannot simply rename the singular ‘targeted’ driver file.

What am I missing or where do I find out details on what exactly to add into the ‘packages’ file?

Thanks in advance!!

You need to blacklist hda driver like this:

Package haiku  {
	EntryBlacklist {
		add-ons/kernel/drivers/bin/hda
	}
}

Hmmm, I think I tried that first and it did not work. I will definitely gtry your version and see what happens.

I will respond with what I discover…

Thank you!

Still a no-go…I copied your complete snippet in the ‘packages’ text file. Rebooted and the sys.log states this:


KERN: HDA: Detected controller @ PCI:0:27:0, IRQ:21, type 8086/284b (1028/01f2)
KERN: loaded driver /boot/system/add-ons/kernel/drivers/dev/audio/hmulti/hda

I guess blacklisting does not work (at least for me)…

Any other alternatives? Like deleting/renaming the ‘hda’ file(s)?

Blacklisting works, and is the only way to filter out these files at least until we move them to separate packages.

Since blacklisting is not working, how can I “force” the Open Sound drivers instead of the HDA driver? Can I move the driver file ‘hda’ elsewhere or will that break Haiku?

The good news is that I can manually ‘blacklist’ the HMulti add-on and HMulti drivers using the {SHIFT} key on bootup, where it finally installs the OSS drivers instead.

I now have sound!!

However, the use of the ‘packages’ text file does not work for blacklisting!! How can we get that working so I can using the {SHIFT} bypass for every boot cycle?

There is no other way to blacklist files than the blacklist file and the blacklist menu. The OS is stored inside a package which you can’t modify.

The blacklist file is working for me and many other people using the opensound driver. So, check carefully the file location, name and contents, there must be something unexpected there that prevents it from working.

1 Like

Post the complete output of the following command (you supposed to run it in the Terminal):

cat /boot/system/settings/packages

Here is the output you requested:

Welcome to the Haiku shell.

~> cat /boot/system/settings/packages
Package haiku {
EntryBlacklist {
add-ons/kernel/drivers/bin/hda
}
}
~>

First of all, thank everyone who participated in this discourse–you are all awesome!!

OK…I played around some more with the ‘packages’ file and many reboots. Here’s what finally works:

Welcome to the Haiku shell.

~> cat /boot/system/settings/packages
Package haiku {
EntryBlacklist {
add-ons/kernel/drivers/bin/hda
add-ons/media/hmulti_audio.media_addon
add-ons/kernel/drivers/dev/audio/hmulti/hda
}
}~>

Why? I believe the last added statement, “add-ons/kernel/drivers/dev/audio/hmulti/hda” was referring to a broken link and it no longer blocked whatever needed to happen for the OpenSound drivers to be installed.

So I now have sound!!! Awesome!!

2 Likes