No sound in qemu

I’m running the latest nightly in qemu. Everything works nicely except the sound.

My qemu config:

qemu-system-x86_64 -machine q35 -cpu host -enable-kvm -m 4096 -smp 2 -vga virtio -drive “file=haiku.qcow2,format=qcow2” -nic user,model=virtio-net-pci -device AC97 -usb -device usb-tablet

qemu runs on a late 2012 Apple Mac Mini with Intel HDA based on Cirrus Logic CS4206 chip.

I’d try with another audio device, HDA (ich6) for example.

Tried with HDA too but the same result :disappointed:

the correct parameter is “-soundhw ac97”.

Thanks but I changed it because it’s deprecated (qemu 7.0.0):

qemu-system-x86_64: warning: ‘-soundhw ac97’ is deprecated, please use ‘-device AC97’ instead

Regarding sound, I have these two options on my Haiku VM: -device hda -device hda-duplex and I do have sound from the VM working.
However I’m using kvm on Linux.

1 Like

Thanks for the tip! I switched to KVM and the sound issue automagically got solved without any kind of configuration :slight_smile: